Road Glide banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,807 Posts
Discussion Starter #1
Okay i don't know if it was anything to do with being hot but. Was out riding some spirited hwy miles when came upon a long line up of cars, so i pulled the clutch in and waited. The line up wasn't moving much (motorcyle accident) about 10 minutes later inching along all of sudden the bike gains a few RPMs to about 1700 or 2000 grand and the bike starts inching forward and i still have the clutch pulled in. Now i have to get on the brake to stop from hitting the car in front of me. Just then i get to the front of the line and it clears a bit 10 mph and i move ahead. I stopped a little past the line up of cars and the bike still idled fast but the clutch was working again. No codes nothing any idea what happened . Rode home and it seems all is good again but haven't had a chance to ride since.
 

·
Registered
Joined
·
6,625 Posts
Clutch may need adjustment.
 

·
Registered
Joined
·
809 Posts
Okay i don't know if it was anything to do with being hot but. Was out riding some spirited hwy miles when came upon a long line up of cars, so i pulled the clutch in and waited. The line up wasn't moving much (motorcyle accident) about 10 minutes later inching along all of sudden the bike gains a few RPMs to about 1700 or 2000 grand and the bike starts inching forward and i still have the clutch pulled in. Now i have to get on the brake to stop from hitting the car in front of me. Just then i get to the front of the line and it clears a bit 10 mph and i move ahead. I stopped a little past the line up of cars and the bike still idled fast but the clutch was working again. No codes nothing any idea what happened . Rode home and it seems all is good again but haven't had a chance to ride since.
sounds like you just heat soaked the clutch, i have had that happen to me multiple times to my roadking.
 

·
Registered
Joined
·
559 Posts
when you get in traffic like that just click it in neutral problem solved.i put a heavier spring in mine,it still gets the creeps if it gets to hot
 

·
Registered
Joined
·
125 Posts
I would do the clutch adjustment. i also had a problem last night, but mind was at the other end, I was going ~70, tach shows 3K, wanted to pass some slower traffic, turn the throttle on, tach goes from 3 to 4 to 5+, but I'm still going 70, wtf. The clutch can't be slipping with only 2500 on the bike. Stopped by the stealership and asked if the clutch adjustment was part of the 1k service, they had no clue. Went home, and the clutch adjustment should have been done per the manual. So i just did the adjustment per the service manual, what a difference, the bike never pulled that hard before. Last week I put the bike on a dyno at a local event ($75) just to see where i was at with FM stage1 setup, was a little dissapointed at the hp number (78 hp, but torque was 96ft-lb). Now i believe that the low numbers was because of the clutch slippage. All is well now.
 

·
Administrator
Joined
·
10,504 Posts
oh how I wish we could still get asbestos coated plates , used ta do parades with the panhead , and smoke just rolling off the clutches :D
 
1 - 6 of 6 Posts
Top