Road Glide banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
253 Posts
Discussion Starter · #1 ·
Ive seen so many posts on here about how crappy the audio is with the stock shield and stock deck etc..etc.. When I got my 15, I wanted no issues at all so I immediately pulled the stock speakers and replaced them with Focal speakers and a Focal amp. This past Saturday night, I rode into work at in the middle of the night for 35-40 miles on the highway. I had time to do some testing.

My results? At 50 MPH, I can CLEARLY hear my stereo at a bit less than half volume with a full face helmet on. At 70 MPH, I kicked the volume up 2 clicks and again, clear as spring water. At 95MPH (I was testing ;)) I was at 3/4 volume with no issues at all.

I don't understand what I'm missing here? I have the stock shield and deck. Am I looking for less quality sound than anyone else? I don't think I am.

I'm really not looking to start a battle with anyone and maybe I just got lucky but please someone tell me what is so bad about this bike's audio system?
 

·
Registered
Joined
·
32 Posts
I think the problem is with the totally stock speakers and amp, cause mine sucks. If you don't mind me asking where you got the amp and speakers and how much? Was the install difficult? Thanks in advance.
 

·
Registered
Joined
·
2,100 Posts
Ive seen so many posts on here about how crappy the audio is with the stock shield and stock deck etc..etc.. When I got my 15, I wanted no issues at all so I immediately pulled the stock speakers and replaced them with Focal speakers and a Focal amp. This past Saturday night, I rode into work at in the middle of the night for 35-40 miles on the highway. I had time to do some testing.



My results? At 50 MPH, I can CLEARLY hear my stereo at a bit less than half volume with a full face helmet on. At 70 MPH, I kicked the volume up 2 clicks and again, clear as spring water. At 95MPH (I was testing ;)) I was at 3/4 volume with no issues at all.



I don't understand what I'm missing here? I have the stock shield and deck. Am I looking for less quality sound than anyone else? I don't think I am.



I'm really not looking to start a battle with anyone and maybe I just got lucky but please someone tell me what is so bad about this bike's audio system?

You went immediately to one of the best sound companies on the market. Most get there by frustration! Lol!


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
593 Posts
You didn't post what flash is in your HU or what the settings are set to. The real frustration is that the HU is basically a computer with apps and the flash and setup have a lot to do with that. On top of that, much like identical computers that don't act exactly the same, it's possible to have what appears to be identical HU setups with very different results. "THAT" is what all of the frustrations are about.

Consider yourself one of the lucky ones and if you every update (flash) your HU cross your fingers and hope that the other shoe doesn't drop.
 

·
Registered
Joined
·
253 Posts
Discussion Starter · #6 ·
the HU flash was just to shut off the internal amp. I didn't activate the rear speakers allowing fade since I don't have any rear speakers and the possibility of them is pretty far off in the future. I got the components from a friend locally and the cost was about $700 with wiring and fuses.

I have the Focal FD4.350 amp and Focal AC165 speakers.

The update thing makes sense. I haven't done anything with those since the first one. (I think there has been one or two more since)
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top