Road Glide banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
When the motor is hot my idle speeds up when stopped in traffic or waiting at red lights. I can give it gas and it slows to normal but after a few seconds it speed up again. Any ideas of how to fix it?

Gary
 

·
Registered
Joined
·
822 Posts
Folks will probably need more details to work with:
Year
Mileage
How modified is it
How high does the idle go...

...More stuff that might be useful.:smile:
 

·
Registered
Joined
·
1,055 Posts
Do you have a Rushmore ('15+) bike? If so the EITMS is probably coming on and shutting down the rear cylinder. Press the INFO button on your right hand controls and it should bring up a screen that shows EITMS. If it says "ACTIVE" when you notice the issue, that is what you are experiencing. Good news is you can turn that function off if you desire.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Yes it's a '15 R G Special. I'll try your suggestion this afternoon. The "service advisor" at HD said he'd never heard of this issue and set me up for 8am Sat. It's till under warranty but I'd just as soon fix it myself rather than give it up for a whole day.
Thanks,

Gary
 

·
Registered
Joined
·
229 Posts
Do you have a Rushmore ('15+) bike? If so the EITMS is probably coming on and shutting down the rear cylinder. Press the INFO button on your right hand controls and it should bring up a screen that shows EITMS. If it says "ACTIVE" when you notice the issue, that is what you are experiencing. Good news is you can turn that function off if you desire.
And you can actually watch it turn from "Enabled" to "Active" and feel the difference. To change from Enable to Disable Turn your throttle in reverse direction till stop point and hold for 10 seconds...
 

·
Registered
Joined
·
362 Posts
With the engine off, turn the ignition on for 5 seconds then off for 5 seconds. Do this 4 0r 5 times. many times this will solve the problem. It's caused by hitting the run off switch to the off position while engine rpm is above normal idle. hope this helps.
 

·
Registered
Joined
·
6,640 Posts
Cycling the ignition switch on then off 5 0r 6 time usually help idle problems. A ignition cycle is turning the switch on then waiting for the engine light to go off the turn the ignition switch off. If that doesn't help then you may have a faulty engine temp sensor.
 
1 - 7 of 7 Posts
Top