Road Glide banner

1 - 13 of 13 Posts

·
Registered
Joined
·
227 Posts
Discussion Starter #1
Starting to notice after 9500miles that the drive train is developing a little vibration. I pull the clutch in and it goes away so I know it's not the tires, and it's not the stereo either as I turned that off to be sure. I have heard that HD had an issue with torque compensators wearing prematurely. MoCo didn't issue a recall, but has acknowledged it at some dealerships. I need to take it in and see if my dealer will fix this under my warranty. Any thoughts?
 

·
Registered
Joined
·
227 Posts
Discussion Starter #3
So I had my bike in for the 10k check and service. I told them about the increased vibration with the motor. I told them about my buddy that has the same bike and had the same issue and they changed the torque comp and it fixed the issue. My dealer told me that couldn't be the issue, so instead they decided to loosen all the motor mounts and the re-torque everything. Well now it is much worse than it was before. So now what? I am sure I'm stuck with this shit now. The vibration is so bad now it's in the seat, handlebars, and floorboards. The fairing was rattling now at low rpm. The mirrors shake like crazy too. I'm so pissed, I guess I should have left it alone. WTF!
 

·
Registered
Joined
·
542 Posts
Tell them you want the crank run out checked?
 

·
Registered
Joined
·
13 Posts
I just repaired my friends 08 RG w 18,000 miles. His vibration would go away when he pulled the clutch and it ended up the inner primary bearing and race on the main Trans shaft. Remove the clutch basket and rotate the shaft look for roughness or excessive play. We also put the updated screaming Eagle compensator in while it was apart, smooth as silk now. Not sure how far you drove it after it was fixed that dealer but the bearing just maybe getting worse. Hope this helps.
 

·
Registered
Joined
·
8,835 Posts
Take it to where your buddy took his bike, any dealer does warranty work. You can always take it back to your dealer and raise hell.
 

·
Registered
Joined
·
227 Posts
Discussion Starter #7
Thanks guys for the input. Sure seems to mean something else is wrong, and if its under warranty yet (6 months left) I wouldn't see why they would fight me on this. Yes, its smooth when you pull the clutch in. And it was super smooth up until about 9000-9500miles, so seems like something prematurely wore out. Like a bearing or compensator. I have a call into them to find out what is the next step. Thanks.
 

·
Registered
Joined
·
111 Posts
Compensator is a common item to create issue such as yours. The comp in your bike is now a obsoleted part. You will have to replace it with the 2015 version.
 

·
Registered
Joined
·
97 Posts
Just because the original dealer said "that can't be it" doesn't mean they are fighting you. It just mean's they're dumber than a bag of hammers, like every other stealer you go to.
If your not comfortable taking it back to them for a second shot, take it to a different one. If its convenient for you to take it back and let them see what a shit job they did through it at em.. Then again, they may jack it up worse…..

Good luck brother
 

·
Registered
Joined
·
111 Posts
here are a few pics of what happens to the stock comp due to lack of lube.

The red paste is fretting of the steel. The new design is not without flaws either but there is a kit aftermarket that can be bought to correct the short comings of the latest design.






 

·
Registered
Joined
·
16 Posts
I'm experiencing the same thing with vibratiion on my '13 RG. When I pull the clutch in it stops the vibrating (kind of feels like a out of round tire or bent wheel feeling (thumping?). I'm also getting what feels /sounds like slop in the tranny when I get on or let off the gas (clank/slap type sound). My bike only has 3900 miles on it. Does all this sound compensator related also?
 

·
Registered
Joined
·
805 Posts
Like everything else, there are good mechanics and poor ones. Ask to speak with there best mechanic, explain what happens and ask HIM what he thinks. Sometimes paper with pictures of dead presidents helps.
 

·
Registered
Joined
·
227 Posts
Discussion Starter #13
Took it back in today to the same dealer. Hopefully they will actually look at the drive train this time. Over the phone they tried to convince me into new tires. I said I'm not an idiot, it's not the tires, and they need to start listening to the customer. Hopefully We don't run out of nice weather before it gets fixed. We shall see. I don't understand the hesitation unless the MoCo won't pay them warranty for diagnostics? That would be one reason to try and push it off as normal or within tolerance. I've been through all this with Victory and that is why I am a HD owner. They wouldn't take care of the issue. I really hope this time it's different!
 
1 - 13 of 13 Posts
Top