Road Glide banner

1 - 14 of 14 Posts

·
Registered
Joined
·
567 Posts
Discussion Starter #1
i just had my dealer install a hogtunes amp & speakers on my 2015 rgs. now i can hear the radio at hiway speeds. they also flashed the radio. on my first ride after picking up bike the radio worked great for about 100 miles. i stopped for a coffee break , & when i started bike ,no radio. all that displays on the screen is the h-d badge & the time!!!! itried turning ignition off & then restart, samething happens. did this a few times -no luck, i finally rode home. any answers!!
 

·
Registered
Joined
·
108 Posts
Did you try hitting the power button on the radio?
When I turn the radio off and leave the bike on it shows that.
 

·
Registered
Joined
·
8,412 Posts
Thanks Bender15, i hit the power button & now the radio works!!!!!:):):)
The toaster always works better plugged in too.:eek:
 

·
Registered
Joined
·
1,082 Posts
Don't sweat it. Heard recently about someone taking their bike in for the cruise not setting. Turns out the switch was off. It happens.
 

·
Registered
Joined
·
4,036 Posts
Don't sweat it. Heard recently about someone taking their bike in for the cruise not setting. Turns out the switch was off. It happens.

I blame it on Forums! We sit here and read thread after thread about all the problems everyone else is having and we convince ourselves that we must have a major issue and never look at the simpler solution. Lol!
 

·
Registered
Joined
·
567 Posts
Discussion Starter #10
i agree with RGKen, i should have read the manual first. new bike is like new car, takes time to know what all the buttons are for. 50 years ago when i started riding the bikes were much simpler.
 

·
Registered
Joined
·
4 Posts
Nanook, after a couple weeks with the Hogtunes what do you think? I just rode my 2015 RGS home last Friday from the dealer and everything I've read about the stock system is so true. What a piece of sh!t for $25k. The aftermarket fairing on my 09 RK was better! Replacing the windshield first thing but I'm still up in the air on what amp/speaker kit i want to upgrade to.
 

·
Registered
Joined
·
567 Posts
Discussion Starter #12
biggins,the hogtunes speakers along with their amp work great up to 3/4 volume. at max volume they are distorted & not clear sounding. but with the amp i only need about 1/2 volume at hiway speed to hear my xm radio clear.if you do install new speakers make sure you also install a amp.i had installed the speakers first & while they were better than stock,they still were not loud enough at hiway speed..good luck!!
 

·
Super Moderator
Joined
·
4,274 Posts
Nanook, after a couple weeks with the Hogtunes what do you think? I just rode my 2015 RGS home last Friday from the dealer and everything I've read about the stock system is so true. What a piece of sh!t for $25k. The aftermarket fairing on my 09 RK was better! Replacing the windshield first thing but I'm still up in the air on what amp/speaker kit i want to upgrade to.

I just got the new ultra for my wife but it has 4 speakers. I think with an amp.
It sounds decent . Not anywhere near my j&m 500 watt, but decent ?
 
1 - 14 of 14 Posts
Top