Road Glide banner

1 - 6 of 6 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter #1
So I was heading towards purchasing the Alpine CDE-HD149BT and I went back to mess with the stock radio and iPod Interface on my 2011 FLTRU. I can get the iPod working in the saddlebag by actually picking what I want to listen to from the iPod (not very useful when riding). So the problem is I have no visual of the band or song names and no control to change it via the handlebar controls. The softkeys still read Artist, Playlist and etc but have no function when I push them. I have checked and the firmware is up to date. I am now thinking it could be the iPod Interface itself. Anybody have this issue before I purchase the Alpine radio and just move on?

Thanks again
 

·
Registered
Joined
·
215 Posts
If you're talking about the HDPDPLUSIII interface, I took mine out because it was just a waste of space. Nothing appeared on the screen and the hand controls seemed useless. Hell, I don't think it even charged the Ipod that well. If I use the Ipod now, I just plug it in the front AUX input. I did solder a rear AUX input on the back of the stock radio (for GPS). Move on!
 

·
Registered
Joined
·
997 Posts
Move on. The HD interface is complete junk. I will never purchase another HD audio product because of this thing that basically does nothing but aggrivate the owner. I actually had good luck with the first version of the HDPDPLUS but I left it in the 11 when I traded it. I purchased the HD version for my 13 thinking it would be better but that was a big mistake.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #4
Thanks, I figured I would be moving on, just needed to put the nail in the coffin from others experience.
 

·
Registered
Joined
·
745 Posts
I had one of those "HPPD...POS" things too. Took it out 'cause it crapped the bed.
Waste of money.
 
1 - 6 of 6 Posts
Top