Road Glide banner

1 - 11 of 11 Posts

·
Registered
Joined
·
211 Posts
Discussion Starter #1
my factory HD system that had the amp installed had zero floor noise or hissing sound when volume was down. Both of my after market systems have a lot of floor noise when the volume is down. The arc audio amp had a lot more, but the RF system also has a decent amount.

is this normal? If not, how do you solve it?

thanks
 

·
Registered
Joined
·
211 Posts
Discussion Starter #4
I used the harness’ that came with the RF kit for the outputs And inputs. so I am not sure.
 

·
Registered
Joined
·
31 Posts
If your AMP is grounded to the battery you could get "white noise" from that. Its better if the ground goes to a common point to the frame. This is just a possibility.
 

·
Registered
Joined
·
211 Posts
Discussion Starter #6
Ok, I don’t see a ground anywhere. I only see the neutral side of the battery power connection.
 

·
Registered
Joined
·
211 Posts
Discussion Starter #7
Or negative and positive I guess it would be, not neutral.
 

·
Registered
Joined
·
1,123 Posts
Some radio / amps induce noise. All you can do is possibly put a ground isolator on the ground wire. Worked on the car world...

Sent from my SM-N970U using Tapatalk
 

·
Registered
Joined
·
165 Posts
There are 2 grounds by the battery. A clean ground and a dirty ground. One for sensors and one for the battery. Might try that
 

·
Registered
Joined
·
28 Posts
Usually if you using a high level install ,(directly from the head unit speaker out to the amp input), It would indicate the gain is to high. If you set the gain beyond half the range, with a high level system often it to much. Louder yes, cleaner no.
 
1 - 11 of 11 Posts
Top