Road Glide banner

1 - 7 of 7 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
got on the bike today and no radio...when you stat bike radio starts up as normal but no sound. i was playing a cd in it last. the lights and harley symbol come on, the clock comes on and works, all the side options are on and it says its on cd and on track 7 but never plays. i have no volume, cant switch media to fm or anything, and i cant turn the radio off with the power button....so basically out of all this the clock works...i've never had the fairing off is there a reset button or anything? or its just screwed.... thanks for any help
 

·
Registered
Joined
·
1,125 Posts
Does yours have the spkr switch? if so make sure it is in the correct position.
 

·
Registered
Joined
·
22 Posts
The radio on my 2012 died at about 8K. Fortunately it was still covered by warranty. The clock worked, but no music. If I had to buy a new one I would look for something aftermarket.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #4
no i dont have a speaker switch. i do have a extended warranty i transferred to my name when i bought it. i guess ill have to go see bout gettin it replaced
 

·
Registered
Joined
·
593 Posts
It's toast. I just had mine replaced under warranty at 5k miles because it would come on (radio worked) but not respond to the buttons or controls. Your extended warranty should cover it, or you can take the opportunity to upgrade.
 

·
Registered
Joined
·
714 Posts
It's toast. I just had mine replaced under warranty at 5k miles because it would come on (radio worked) but not respond to the buttons or controls. Your extended warranty should cover it, or you can take the opportunity to upgrade.
[If it were me] I'd get it covered underwarranty and sell it (~$350-$400) and use that to upgrade.
 

·
Registered
Joined
·
137 Posts
Going to say yes, my 13 custom with 9k on it, is in the shop for issues (have multiple) first the screen will blank out but still have control over vol and station, 2 radio freezes I have the screen no buttons work and the radio plays at vol and same station, 3 the headphone icon comes on in place of the speaker and I loose all sound but have control over station and vol, the last is sometimes it just keep changing the station when this happens turn the radio off and let it sit a few min and she will work again. good luck with yours.
 
1 - 7 of 7 Posts
Top