Road Glide banner

1 - 19 of 19 Posts

·
Registered
Joined
·
228 Posts
Discussion Starter #1
I posted a little while ago about my grips not getting hot.
The level from 1 to 6 makes little difference in the heat.
I asked the dealer and the gave me a new left grip with the controller on it and it still basically the same .. sometimes they get hot but most times just barely warm. My brother has 2010 Ultra and those stock grips get mutha Fu*!ing hot..
I am not sure what to look for next and I know there are plenty of guys out there with kahuna heated grips that say they get hot.. any suggestions would be helpful.

Sent from my SM-N960F using Tapatalk
 

·
Registered
Joined
·
236 Posts
Last set I put on my Heritage I wasn’t impressed.
 

·
Registered
Joined
·
1,934 Posts
Wonder if there could just be a weak connection somewhere?
 

·
Registered
Joined
·
228 Posts
Discussion Starter #4
Its a bit strange at times because I just got off the bike a few minutes ago and the grips got hot for that ride...

Sent from my SM-N960F using Tapatalk
 

·
Registered
Joined
·
4,838 Posts
Maybe a good time to start over, disconnect and reconnect.

Mine work mint.
 

·
Registered
Joined
·
1,375 Posts
I have a set on order but will say my last set of Harley heated grips you couldn't put it past 3 they got so hot. I made the mistake of wearing my heated gloves (not plugged in) and the grips heated the wires in the gloves so much, I had blisters from the wires getting so hot!

I'd say you have a loose connection or a bad ground
 
  • Like
Reactions: jstucker1976

·
Registered
Joined
·
228 Posts
Discussion Starter #7
I have a set on order but will say my last set of Harley heated grips you couldn't put it past 3 they got so hot. I made the mistake of wearing my heated gloves (not plugged in) and the grips heated the wires in the gloves so much, I had blisters from the wires getting so hot!

I'd say you have a loose connection or a bad ground
There is not much too it.. two wires and the plugs lock when connected.. plus I have changed out the left controller grip and it's pretty much the same.. I will see what's happening on the right side .. but that's all factory...

Sent from my SM-N960F using Tapatalk
 

·
Registered
Joined
·
79 Posts
Could the inside of your bars have sliced and exposed a part of the wire maybe? Or if not perhaps there is a short somewhere down the power wire? I have heard this comment more than once. I got lucky though and mine work great.
 

·
Registered
Joined
·
228 Posts
Discussion Starter #9
Checked the right side grip and the internal connection was seat correctly.. checked all plugs behind the cluster unplugged and re plugged but all looked perfect...

Sent from my SM-N960F using Tapatalk
 

·
Registered
Joined
·
341 Posts
Its a bit strange at times because I just got off the bike a few minutes ago and the grips got hot for that ride...

Sent from my SM-N960F using Tapatalk
Is the right side plugged all the way in? There is a cap on the end of the right grip. Pop it off and make sure the two pin connector is plugged all the way in. If that doesn’t get it then check wires in the instrument cluster.
 

·
Registered
Joined
·
193 Posts
I would be getting out the voltmeter and checking everything. The connector under the nacelle where the right and left come together is a spot to start. And then under the right side grip end cap. If you don’t get power to the right side, the left doesn’t work either. It has to make the complete circuit to heat up.
 

·
Registered
Joined
·
228 Posts
Discussion Starter #12
I would be getting out the voltmeter and checking everything. The connector under the nacelle where the right and left come together is a spot to start. And then under the right side grip end cap. If you don’t get power to the right side, the left doesn’t work either. It has to make the complete circuit to heat up.
It's not that they don't work, it's that they don't get very hot.. the difference in heat between 3 and 6 seems like there is no change

Sent from my SM-N960F using Tapatalk
 

·
Registered
Joined
·
14 Posts
I posted a little while ago about my grips not getting hot.
The level from 1 to 6 makes little difference in the heat.
I asked the dealer and the gave me a new left grip with the controller on it and it still basically the same .. sometimes they get hot but most times just barely warm. My brother has 2010 Ultra and those stock grips get mutha Fu*!ing hot..
I am not sure what to look for next and I know there are plenty of guys out there with kahuna heated grips that say they get hot.. any suggestions would be helpful.

Sent from my SM-N960F using Tapatalk
When I did the install on my 2020 RGS, I found that the wiring connector on the throttle side was wired backwards .
 

·
Registered
Joined
·
228 Posts
Discussion Starter #15
When I did the install on my 2020 RGS, I found that the wiring connector on the throttle side was wired backwards .
How did you determine that it was wired backwards.. what did you do to test that and what problems were you experiencing..

Sent from my SM-N960F using Tapatalk
 

·
Registered
Joined
·
2,381 Posts
I have a set of those grips on my 19 and they will almost blister your bare hand. but the internal connections are not all that great. Just little pins and sleeves.
 

·
Registered
Joined
·
14 Posts
How did you determine that it was wired backwards.. what did you do to test that and what problems were you experiencing..

Sent from my SM-N960F using Tapatalk

The white and black wire in the throttle side were swapped in the connector, white should go to the red wire and black should go to black wire.
 

·
Registered
Joined
·
341 Posts
The white and black wire in the throttle side were swapped in the connector, white should go to the red wire and black should go to black wire.
I noticed that too, but then realized what difference does it make? It’s just a color.
 

·
Registered
Joined
·
377 Posts
I had the factory installed heated grips on my 13 Ultra Limited, they were entirely rubber all the way around. On this 17 RGU, I had them add the grips. I forget the model but they were one of the few that were heated and had a 1.6" diameter. These are chrome and rubber. Its only the rubber that gets hot. While these do get hot, because my hand is not against rubber all the time, they don't do as good a job at keeping my hands warm.
 
1 - 19 of 19 Posts
Top