Road Glide banner

1 - 6 of 6 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
I just installed a pair of Kappa 62.11i in my '15 and while sitting in the garage you can't turn them all the way up without your ears bleeding. I went for a quick ride and the volume is gone, the stock speakers were louder. I have turned off the AVC and also tried it at different levels with no success while riding. I just had the bike serviced and the dealer installed the firmware update as well. I am not running an amp yet but from all the post I have read on the Infinity Kappa speakers just installing them alone would/should help with the sound. If anyone has had this issue or knows how to remedy the small sound while riding I could use some help.
 

·
Registered
Joined
·
8,609 Posts
I just installed a pair of Kappa 62.11i in my '15 and while sitting in the garage you can't turn them all the way up without your ears bleeding. I went for a quick ride and the volume is gone, the stock speakers were louder. I have turned off the AVC and also tried it at different levels with no success while riding. I just had the bike serviced and the dealer installed the firmware update as well. I am not running an amp yet but from all the post I have read on the Infinity Kappa speakers just installing them alone would/should help with the sound. If anyone has had this issue or knows how to remedy the small sound while riding I could use some help.
Don't believe everything you read on the enterweb. :) Did you turn the mids so they're pointed in toward your Mellon ?
 

·
Registered
Joined
·
66 Posts
Discussion Starter #3
I did rotate the tweeters towards my noggin and have the DB switch set at 0. I haven't tried the +3 yet, but I think that only improved the highs.
 

·
Registered
Joined
·
8,609 Posts
I did rotate the tweeters towards my noggin and have the DB switch set at 0. I haven't tried the +3 yet, but I think that only improved the highs.
Seems strange, since they play loud in the garage. Do they still play loud at stand still with the bike running?
I've only run them off the amp, and they're loud , moving or not.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #5
Not as loud as the stock speakers while stopped at a light and they seem to pulse while riding. I guess that means I have to buy an amp too. I was just going to do speakers first and an amp later down the road.

I'm thinking of going the route of a SoundStream since I've already ran a PBR 300x2 on my 07. It was a good amp but did get very hot.

Since I'm only planning on a 2 speaker system I just need to find the right amp. Now the search is on!!!
 

·
Registered
Joined
·
8,609 Posts
Not as loud as the stock speakers while stopped at a light and they seem to pulse while riding. I guess that means I have to buy an amp too. I was just going to do speakers first and an amp later down the road.

I'm thinking of going the route of a SoundStream since I've already ran a PBR 300x2 on my 07. It was a good amp but did get very hot.

Since I'm only planning on a 2 speaker system I just need to find the right amp. Now the search is on!!!
The Soundstream is a nice amp. Some folks seem to have problems with radio reception. I only noticed a little weakness in reception, not a total loss.
 
1 - 6 of 6 Posts
Top