Road Glide banner

61 - 80 of 148 Posts

·
Registered
Joined
·
37 Posts
I have a 19 RGS, that's the 1" clamp correct?
I'm hoping not! I've ordered 1.25" clamp which I believe is the right size for 2015 and up.
What are the clamp sizes for 2017 RGS? I have always wondered but not sure. I was looking on there website and it just ask’s you size you want not what model you buying for. Hell idk, I’ve never looked at this year’s clamp area
 

·
Registered
Joined
·
5,205 Posts
What are the clamp sizes for 2017 RGS? I have always wondered but not sure. I was looking on there website and it just ask’s you size you want not what model you buying for. Hell idk, I’ve never looked at this year’s clamp area
I believe '15 and up are 1.25". I hope someone can confirm this.

Sent from my XT1710-02 using Tapatalk
 

·
Registered
Joined
·
75 Posts
Ok, ordered 16" Spearhead today. Officially every custom order is quoted 4 weeks, but Ret says probably quicker.
Now I know I need longer hydraulics, so I'm ordering +4, HD dealer service guy said +6, but if 14" fits stock, 16" should easily fit +4. I am not looking forward to the hyd line install. Ordered Magnum Chromite. I used Magnum website to figure part numbers then ordered on ebay. $300 on Magnum, $224 and free shipping on ebay.
Any hints and tips on running new lines would get appreciated.


Sent from my SM-G930V using Tapatalk
 

·
Registered
Joined
·
37 Posts
Bought my set of 14” got them for under $400 like someone said. Just wait a day or so and you’ll get a 10% first timers discount. Actually could probably just go on and use the coupon code of first and would get it. Maybe not but worth a shot if you don’t want to wait.
 

·
Registered
Joined
·
30 Posts
This is killing me!!! I ordered the bars right after they were available.....

Found a "KILLER DEAL" on a Mustang seat on closeout....

Ordered Heated grips.....

AND....

I'm still working out of town....

I won't get home till Thursday to even begin to try and install stuff...

SO

How have your guy's install's been going?

I've watched the KST install video several times....It looks "EASY", but, again, it's the internet, and trained professionals....

I'm a ham fisted monkey....

I can't fricking wait....
 

·
Registered
Joined
·
3,929 Posts
Ok, ordered 16" Spearhead today. Officially every custom order is quoted 4 weeks, but Ret says probably quicker.
Now I know I need longer hydraulics, so I'm ordering +4, HD dealer service guy said +6, but if 14" fits stock, 16" should easily fit +4. I am not looking forward to the hyd line install. Ordered Magnum Chromite. I used Magnum website to figure part numbers then ordered on ebay. $300 on Magnum, $224 and free shipping on ebay.
Any hints and tips on running new lines would get appreciated.


Sent from my SM-G930V using Tapatalk
Looking forward to seeing pics of these on your sled
 

·
Registered
Joined
·
37 Posts
Install was pretty easy really. He must have extended cables in the video (clutch side is tight) and not as loose as his looks but it works. Just have to play around to get just enough slack to make it work. Also not sure if I screwed something up on the wiring because my check engine light is on now.... although upon install nothing was too difficult about the wires. So who knows... raining today, can’t take her out for a spin yet but all functions seem to work electrically in my garage so not sure why the engine light.
 

·
Registered
Joined
·
773 Posts
Install was pretty easy really. He must have extended cables in the video (clutch side is tight) and not as loose as his looks but it works. Just have to play around to get just enough slack to make it work. Also not sure if I screwed something up on the wiring because my check engine light is on now.... although upon install nothing was too difficult about the wires. So who knows... raining today, can’t take her out for a spin yet but all functions seem to work electrically in my garage so not sure why the engine light.
If you didn't pull the main fuse when you unplugged the cables you will get Check engine light.... Clear the codes and it should be fine
 

·
Registered
Joined
·
741 Posts
Discussion Starter #73
I did not. Didn’t even think about that. How do I clear the codes? Unhook the battery?
Fuel Moto has instructions on how to clear the codes. I did the same thing a couple weeks and its really a simple process that I cannot remember all the steps. I know you start out by holding down the trip odeometer until the display shows DIAG and then turn the ignition switch to acc. Make sure the on/off switch is in the off position before holding down the trip odometer.
 

·
Registered
Joined
·
37 Posts
I think I am good. I used my FP3 to clear the codes. Forgot that was an option. At least for now the check engine light is off. Wet and cold here today so couldn’t take it out after I cleared them to make sure all was good.
 

·
Registered
Joined
·
189 Posts
This is killing me!!! I ordered the bars right after they were available.....

Found a "KILLER DEAL" on a Mustang seat on closeout....

Ordered Heated grips.....

AND....

I'm still working out of town....

I won't get home till Thursday to even begin to try and install stuff...

SO

How have your guy's install's been going?

I've watched the KST install video several times....It looks "EASY", but, again, it's the internet, and trained professionals....

I'm a ham fisted monkey....

I can't fricking wait....



Just installed the spearheads. Very straightforward if you follow the video. If it wasn't for the heated grips, would have been done very quickly.
 

·
Registered
Joined
·
189 Posts
Tell me about the "HEATED GRIPS" issue.....

Because, I've got those to install too.......

I actually have not gotten them installed yet. The wiring that came with the grips were wrong for the RGU as there is no plug-in under the faring. So I purchased the wiring kit that is supposed to allow you to wire from battery, around tank and then up to the bars, but there was not a harness long enough to make the trip. Need to get some wire and pull the parts off the bike again to make it happen. Extremely frustrating!
 

·
Registered
Joined
·
37 Posts
I have the 17 RGS for reference.. the heated grips don’t plug into the 2 extra plugs in the harness under the speedo and tach? Mine has 2 extra plugs, I only assumed it was for the heated grips addition. I was told all these 15-19 come prewired ready for heated grips.
 

·
Registered
Joined
·
189 Posts
I have the 17 RGS for reference.. the heated grips don’t plug into the 2 extra plugs in the harness under the speedo and tach? Mine has 2 extra plugs, I only assumed it was for the heated grips addition. I was told all these 15-19 come prewired ready for heated grips.
Rumor is that the RGS does have the extra plugs, the RGU does not.
 
61 - 80 of 148 Posts
Top