Road Glide banner

1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hi all. Anyone put the lighted control switches on their street glide or road glide? If so...how or what do you do with the comm switch? I was going to just trade it out for the blank that came with the bike but that one doesn't let light come through. Any ideas? Is there another part I'm missing? Part is 71500248B

Thanks.

Sent from my SAMSUNG-SM-N910A using Tapatalk
 

·
Registered
Joined
·
815 Posts
Have em, love em! I bought mine because I installed a CB Module and needed the PTT switch. 17 RGU



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
Have em, love em! I bought mine because I installed a CB Module and needed the PTT switch. 17 RGU



Sent from my iPhone using Tapatalk
Nice. I installed mine tonight. They are great but that extra switch is annoying to me. If I hit it accidentally it throws a code. I tried taking the switch apart and swapping the blank on the original switch but the original one doesn't allow the light to shine through that one bottom button. Looks stupid with everything lit up except that one. I thought perhaps there was a piece missing from the kit or I needed to order a separate blank for it.
Any info?

Sent from my SAMSUNG-SM-N910A using Tapatalk
 

·
Registered
Joined
·
154 Posts
I installed those on my 2016 RGU a few years back. My display just says no CB installed and then goes back to normal screen. I've gotten used to the switch and rarely hit the CB switch now. I think you'll just get used to it, give it time.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
I installed those on my 2016 RGU a few years back. My display just says no CB installed and then goes back to normal screen. I've gotten used to the switch and rarely hit the CB switch now. I think you'll just get used to it, give it time.
Yea. Thanks. They are nice to have at night. I would think HD would have a blank for RGS tho. Thanks.

Sent from my SAMSUNG-SM-N910A using Tapatalk
 

·
Registered
Joined
·
18 Posts
Discussion Starter #8
I pulled it out and put the cover from the orginal in....looks stock no problems
Sorry for the late reply. Been busy with work..damn jobs!

What did you pull out? I took the blank off with the 2 small torqx screws and swapped them but that left the toggle unlit. Sorta weird looking. Were you able to remove the blank itself?
 

·
Registered
Joined
·
13 Posts
You might check with the dealer to see if they can program out the switches with no function, like the PTT if it isn't used. They can swap the cruise with the PTT from one side to the other so they may be able to program out the feature. Of course it probably won't be free.
 
1 - 9 of 9 Posts
Top