Road Glide banner

1 - 5 of 5 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #1
OK.. So i went for my 1000 mile service and a couple of days after i got my my bike I'm hearing a clanking sound when ever I pull the clutch in and when I release it... so its like "pull clutch - clank - Shift to 2nd (or third etc) clank of the shift - then release cluth and clank again.." I also hear if I'm cruising in gear.. for example about 40 on 3rd and I twist the throttle.. i hear a clank in what seems to be the gears or clutch... sometimes if I release the throttle quickly as well.. also if im cruising and Im coming to a red light and say im in third or 4th and im letting bike slow down.. it'll start clanking (more like rattling) - I know its because gears are high for speed going .. but it sounds like something is going whacky under primary cover.. went to dealer for him to hear and he couldn't take it for a spin at that time so I also showed him that if I have the bike in gear and i flick the clutch lever i get clanking sound.. he stated that was normal.. and I explained if it was normal than why did I not notice before and only noticed since last week... seems there is something loose inside the Primary.. at the end he asked me to bring it in next week so they can open her up and check it out... anyone every experience similar?
 

·
Registered
Joined
·
723 Posts
Rattling or clanking is not normal. If your dealer says it is than you need to find a new mechanic. They do make noises. It is not unusual for a clank in 1st gear. It is not right but not unusual. Mine almost always clanks going into 1st when cold but after it warms a bit it usually stops or decreases tremendously. I am doing my 65,000 mile service today before heading out for a week in the mountains.

You may have a mis-adjusted clutch or something more serious. Take a look at your fluid. At 1,000 miles it should be relatively clean. It wont be pristine as it will have some clutch dust/material in it but it shouldn't have any metal in it.

Okay I just looked at the date of your post almost 4 months ago. So what did the dealer say was wrong?
 

·
Registered
Joined
·
1,110 Posts
They should have changed trans fluid at service, make sure they refilled it. I know it sounds stupid, but you would not be the first to have this happen.
 

·
Registered
Joined
·
8,826 Posts
I would have left the bike there.
 
1 - 5 of 5 Posts
Top