Road Glide banner
  • Hey Everyone! Vote for the Site Favourite BOTM winner for the year of 2022 HERE!
1 - 20 of 54 Posts

· Registered
Joined
·
152 Posts
Discussion Starter · #1 ·
RGS 2020 with 23K miles; couple times in the past six months my bike refused to crank, and it feels as battery failing. I waited few seconds and it started with no problem. Last time I had to use my booster to start it. Following advised from other riders, saying in Florida you be lucky to get three years of battery, so I end up buying a lithium battery from HD dealership. Two weeks with the new battery it did it again yesterday, it wouldn't start and feels as low battery, on my second attempt there was nothing, no juice no lights nothing, as if dead battery. I was stranded 150 miles from home.
Tow it to a local HD dealership. Dealership recap: battery had 1 volt in it, after disconnecting the battery and tested battery was at 14 volts, they say it has an internal mechanism that shut down??!! They have no clue on what caused it or what might be wrong with the bike, as no code in computer showed up.
This issue never happens when bike was cold, always when stopping for few a minute and try to start it again
Any ideas guys of what could be wrong here???

Thanks
 

· Registered
Joined
·
152 Posts
Discussion Starter · #3 ·
I am not mechanically inclined :(
My only option is HD for diagnostic??!!

But the first three times that happened it cranked with no issues at all. The first time I continue riding all night and probably crank it four more times that night with no issues, same thing the second and third time...no issues afterwards
 

· Registered
2019 RGS
Joined
·
6,567 Posts
I am not mechanically inclined :(
My only option is HD for diagnostic??!!

But the first three times that happened it cranked with no issues at all. The first time I continue riding all night and probably crank it four more times that night with no issues, same thing the second and third time...no issues afterwards
You replaced the battery. And then the bike put that battery into its “save mode” there’s an issue somewhere in the Stator or the Regulator. Or a short in the wiring somewhere between. When was the last time that motor was gone into and what was done?
 

· Registered
Joined
·
152 Posts
Discussion Starter · #5 ·
You replaced the battery. And then the bike put that battery into its “save mode” there’s an issue somewhere in the Stator or the Regulator. Or a short in the wiring somewhere between. When was the last time that motor was gone into and what was done?
What do you mean by ..." motor was gone into and what was done?"
 

· Registered
Joined
·
152 Posts
Discussion Starter · #7 ·
Who worked on it last? What was done? If it has not been worked on prior to this issue then something went bad. It happens. Just have to figure out what now.
Always been taken to my local HD dealership. Last in for service was the 20K service. I did call my HD for new battery and explained what I was experiencing, he suggested a diagnostic first before replacing the battery. I was so convinced it was the battery, so I replace it Myself .... 😕
 

· Registered
2019 RGS
Joined
·
6,567 Posts
Always been taken to my local HD dealership. Last in for service was the 20K service. I did call my HD for new battery and explained what I was experiencing, he suggested a diagnostic first before replacing the battery. I was so convinced it was the battery, so I replace it Myself .... 😕
Time to go in. Could be as simple as the regulator. It’s a bolt and a plug all done. My buddy has a 2022 and with 3k miles his went bad.

Good luck for sure and please update us as to what you find out.
 

· Registered
Joined
·
7,518 Posts
You described the classic symptoms of a compensator sprocket going bad .
The bike starts good when cold but you have starting issues when the bike is hot.
When my compensator went bad the bike had a hard time starting when the engine was hot , I experienced starter grinding and starter stall where the bike would not even turn over.
Just a suggestion but you may want to look into the compensator sprocket , I had 3 HD compensators go bad and right now I am on the 4th compensator which is a Baker which has lasted the longest.

Good Luck
Mark
 

· Registered
Joined
·
152 Posts
Discussion Starter · #16 ·
You described the classic symptoms of a compensator sprocket going bad .
The bike starts good when cold but you have starting issues when the bike is hot.
When my compensator went bad the bike had a hard time starting when the engine was hot , I experienced starter grinding and starter stall where the bike would not even turn over.
Just a suggestion but you may want to look into the compensator sprocket , I had 3 HD compensators go bad and right now I am on the 4th compensator which is a Baker which has lasted the longest.

Good Luck
Mark
Thanks Mark, you also have the 131 kit?

Also, if is the compensator, would the dealership find the problem during a diagnostic?
 
1 - 20 of 54 Posts
Top