Road Glide banner

1 - 5 of 5 Posts

·
Registered
Joined
·
510 Posts
Discussion Starter #1
I have a 18 RGS with just over 7K miles on it. I just recently started noticing a chatter/tapping/ticking like noise coming from the right side of the engine. The sound seems to be just above the air cleaner where the upper rocker boxes are. This is happening after the bike has been running for a while and the engine is pretty hot. The sound is only when the bike is in gear and decelerating. If i pull the clutch and let go of the accelerator i don't get that chatty noise, so its obviously when the engine is under load. Yesterday i rode about an hour at hwy speeds, then when i was in normal traffic i started hearing it when i let go of the throttle. Anyone else have a similar experience. Chatty is the only word i can find to describe it. Maybe more like a tapping ticking sound.
 

·
Registered
Joined
·
4,074 Posts
I have a 18 RGS with just over 7K miles on it. I just recently started noticing a chatter/tapping/ticking like noise coming from the right side of the engine. The sound seems to be just above the air cleaner where the upper rocker boxes are. This is happening after the bike has been running for a while and the engine is pretty hot. The sound is only when the bike is in gear and decelerating. If i pull the clutch and let go of the accelerator i don't get that chatty noise, so its obviously when the engine is under load. Yesterday i rode about an hour at hwy speeds, then when i was in normal traffic i started hearing it when i let go of the throttle. Anyone else have a similar experience. Chatty is the only word i can find to describe it. Maybe more like a tapping ticking sound.
Possible exhaust leak. That would be the first thing I would check. See if your exhaust stud lock nuts are snug where the header goes into the head. They have a pretty low torque spec so don't go crazy tight on them or you could end up with a bigger problem. I've had one come off completely before so it is a regular check for me at every service.
 

·
Registered
Joined
·
510 Posts
Discussion Starter #3
Thanks for the advice i will check that especially since they are catless stock headers i put on a few months ago myself LOL.
 

·
Registered
Joined
·
6,743 Posts
Possible exhaust leak. That would be the first thing I would check. See if your exhaust stud lock nuts are snug where the header goes into the head. They have a pretty low torque spec so don't go crazy tight on them or you could end up with a bigger problem. I've had one come off completely before so it is a regular check for me at every service.
Bingo
 

·
Registered
Joined
·
782 Posts
Do you have an oil style air cleaner or are you still running the OEM airbox? Sometimes with the aftermarket open air cleaner assemblies, you will hear the throttlebody plate chattering more because of the open airbox
 
1 - 5 of 5 Posts
Top