Road Glide banner

1 - 16 of 16 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter #1
I have a 2001 95" Screamin' Eagle with the dreaded Magnetti-Morelli fuel injection. The bike runs well but... I have this annoying hesitation more than likely cause by a rich mixture that causes the bike to stutter when it is on a load (hills, full throttle) at about 2800-3100 rpm. I could probably just live with it, but it is getting to the point where I have to take it to the stealer at the beginning of the season for an "adjustment" which as always a $250+ deal.

I've seen the Zipper's Thundermax kit that swaps out the entire EFI at a cost of about $2500. I have heard of an S&S kit that swaps the CPU but keep the EFI, adding O2 sensors.

Does anybody have any info on running either? Or, on any other fix? I just dyno'd (free Dyno day at my stealer this past weekend) and I'm sitting at approx. 86 tq & 95 hp on the stock motor with a stage 1. I am hoping that I could push those numbers over 100 with an upgrade to my EFI. Is this a pipe dream?

THX!
 

·
Registered
Joined
·
79 Posts
Discussion Starter #4
My issue with swapping to a carb is that I live at 7100' and ride the Rockies frequently taking me up to 13,000'. I also have 80* days and 30* nights. I don't know enough about a carb swap to know if these conditions would make it more aggravation than it'd be worth. Is there a "go to" install write-up you guys can point me to?

I did run across the Horsepower Inc. upgraded throttle body but I can't find anybody who has ran one. Harley also offers their upgraded ECM that has the ability to download the maps from the S&S VFI module. Haven't heard anybody running this either. Supposedly though, you can make it a wide band O2 sensor upgrade.

I can't be the first guy to want to upgrade. Any info on these to help me with the elimination process would be appreciated!
 

·
Registered
Joined
·
400 Posts
I did the Tmax replacement on my 01 RK with a 95" build, ported and polished heads, gear drive cams, oil pump, cam support plate, Baker 6 speed, etc. Bike ran great with auto tune on the Tmax. Was pushing 100/100 power. Got 32 MPG max but could run away from the newer bikes. There are only a few people that can tune that setup right to get the maximum performance. PM me if you want more details.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
29 Posts
I just had the zippers T max for MM replacement installed couple of weeks ago,(Thanks Scott!!) WOW what a difference was worth every penny,feels like totally new bike,now my Hillside 98"build really rocks.Instant starting, rock solid idle,and the throttle response is right there.the canned map from zippers was right in the zone and i could feel the autotune learning with every ride and after a1000mi Im real happy,i had a power commander 3 on it and after 2 dynotunes $$$$ it still ran poorly. i would stay away from those piggyback set ups!,If you like the bike and are going to keep it i say go for it, you wont regret it.


2000 SERG hillside 98" stg 1 heads,andrews 37cams,D&D fatcat 2-1, Tmax w/autotune.
 

·
Registered
Joined
·
2,001 Posts
I did the carb swap to my 01Rg,it was the best mod i could have done,now with that said you may want to check for the availability of the factory sub wiring harness that you will need,it may have been discontiued,its about a 3-4 hr conversion,now did you say what type of tuner you are running,i was running a early power commander,and it had a hiccup at about 2200 to 2500 rpm will cruising,but noy under power,i chased it for a couple yrs,then did the switch,i talked to the service manager of a shop in Indiana and he told me the hiccup was in the power commander,and that it could be removed.
 

·
Registered
Joined
·
79 Posts
Discussion Starter #10
Any idea of a part number for Namz? I can't find anything like it on their site...
Thx
I got a reply from Namz. Here is the info for anybody for future reference...
Ignition Harness 32435-00 $129.99 from Namz (2000 Ultra models with cam & crank position sensors)
Ignition Harness 32435-01 $129.99 from Namz (2000-2001 Glide models w/ crank position sensor only)
 

·
Registered
Joined
·
79 Posts
Discussion Starter #11
Well... I installed the new TPS and have had to adjust it to .275 and then the cold idle to .650 twice now. I still have some crazy idle issues with it either too low or too high. I've also added a new problem in that it now backfires like crazy on decel. I will assume that the cracks in the rubber breather hoses coming from the motor to the air cleaner have something to do with that. Looks like I will pony up for the new ECM. As was posted earlier, I am assuming that my first TPS was going but wasn't giving off any fault codes. By swapping in a new TPS, that triggered the ECM now and I'm willing to bet that I have a "bad TPS" code now. Took it for a run on Sunday and the throttle response was not smooth at all. About the only way to describe it was that it was "gravely" until I got on it hard at about 4000 rpm.

Stay tuned sports fans!
 

·
Registered
Joined
·
2,091 Posts
you may want to check for the availability of the factory sub wiring harness that you will need,it may have been discontiued.
Yes, it's (32435-97) listed as Obsolete. In 2007, I converted my 1998 Ultra to use a Stock CV carburetor I got at a great price off eBay. (Buy I did have a Carb Kit installed) The harness was obsolete then. So I took a FI harness I got "On the Cheap", also off eBay and made my own using the Factory wiring diagrams.

My issue with swapping to a carb is that I live at 7100' and ride the Rockies frequently taking me up to 13,000'.
I was worried about the changes in altitude when I traveled. But I found that the CV carburetor adjusts (To some extent) to compensate for changes in barometric pressure. I only saw a slight change in mileage when traveling in higher elevations with mine adjusted to ride in So. California..

This was my Ultra, totaled in 2009 and replaced with my current RG.
 

·
Registered
Joined
·
79 Posts
Discussion Starter #14
Well, decal popping almost all but went away. But, my cold/hot idle has been messing with me big time! I'd set it using a multimeter. I would set it at .275 then the cold idle at .650, warm up the bike and then adjust the warm idle to 950-1000 rpms. Went for a good ride and my bike idled at 1500-1800 at every stop. Did the entire adjustment again. Took it out for another good ride and the bike would not idle above 500.

So, with the TPS being new, I am thinking it is the ECM. My bike is at the stealer as we speak getting the new ECM (HD part# 41000012A) programed. The new ECM comes blank and the stealer has to put in the initial program (thinking HD's plan to make a few $$$). They will put it on the dyno and fine tune it to my motor/SE AC/Rineharts.

Keep your fingers crossed!
 

·
Registered
Joined
·
1,034 Posts
@ Yzergod;
so how did it go? I'm having some M&M blues myself. I was also considering the Thundermax for my '01 FLTRSEI2. But the price tag is a little steep for a "GI Joe"...
But I've read on other forums that swapping the ECM for a new one would be a good idea. Does H-D still offer their "service touring ECM" for the M&M? It's easy to find a replacement for the Delphi (eBay etc,)but not for the Italian...
 
1 - 16 of 16 Posts
Top