Road Glide banner

1 - 18 of 18 Posts

·
Registered
Joined
·
487 Posts
Discussion Starter #1 (Edited)
my bike sat outside all last night in the cold rain because i forgot my elcheapo bike cover on my weekend trip.

when i went to start it up this morning to bring it under the front door awning of the hotel it felt like it was in limp mode. i was twisting the throttle but the engine was barely reving and no check engine light was on.

i felt the pit in my stomach as i was thinking what i was going to have to go through to get my bike fixed on a rainy sunday for my trip back home.

i parked under the awning, turned my bike off, and as i was getting off i pulled the throttle grip right off its sleeve.

i think performance machine (roland sands design) should think of using a better glue. these grips arent cheap.
 

·
Registered
Joined
·
5,206 Posts
From the looks of the background of the pix you've made it home. That's a good sign. What did you do, ride it home without the grip cover?
 

·
Registered
Joined
·
487 Posts
Discussion Starter #3
thanks yeah, i made it home. i put the grip cover in my saddle bag and used the throttle as it is in the pic.
 

·
Registered
Joined
·
487 Posts
Discussion Starter #7
haha i know. the front desk lady was nice enough to give me a large trash bag to cover my seat. so no swamp ass. :D
 

·
Shark of the Month December 2013
Joined
·
679 Posts
My HD Edge Cut grips did the same thing. I just took it off, scuffed the tube down good with sandpaper and super glued it back on.
 

·
Registered
Joined
·
487 Posts
Discussion Starter #10
My first two PM grips pulled off the sleeve on the throttle side right after install. Third set is going ok so far. But if it happens with this set I am done with them.

This is my thread on the issue.

Performance Machine = Sketchy quality???
thanks for the link. after reading that i think i'll put my HD aileron grips back on. i'm glad it happened to me in the parking lot and not going down the road at 70 mph.
 

·
Registered
Joined
·
2,012 Posts
SFO - Sh*t Falling off

I hear you. I shed wheel weights frequently. Had an issue on my way back from Florida with my after market ignition cover. The vendor's adhesive was fine, but it pulled the MoCo plate off the ignition switch. Went into the store and found some super glue by Gorilla. If PM won't replace yours, Put a bit of Gorilla on it. :D
 

·
Registered
Joined
·
487 Posts
Discussion Starter #16
i filled out the contact form i found on their face book page. it says allow 24 hours for a reply. i'll let you know if i get a response.
 

·
Registered
Joined
·
487 Posts
Discussion Starter #17 (Edited)
got an e-mail from PM telling me they were sorry and to take them to where i bought them and the vendor will contact them and PM will take care of it and get me new ones.

i e-mailed back that i dont remember where i got them and dont have a receipt. that i bought them online and with everything ive bought for my bike i cant pinpoint that purchase.

waiting on reply.

but i still feel like maybe i should go buy some strong glue and glue it myself. i mean if theyre still using the same glue whats to stop it from happening again? i've got a 10 day trip to new england coming up the first of june and i'm sure i'm going to get stuck in the rain again at some point and ive lost confidence in the grip.
 

·
Registered
Joined
·
487 Posts
Discussion Starter #18
have been in contact with rick and Ian at PM by e-mail and phone.

new set of grips coming. fantastic customer service. i'm a happy camper.:D
 
1 - 18 of 18 Posts
Top