Road Glide banner

1 - 2 of 2 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
I am absolutely at wits end on this one. I have a MOTO Z3 Verizon smart phone. I play spotify through it to my 2017 RGU stock head unit (6.5) Until about 4 weeks ago, the interface worked fine. However, after an apparent android upgrade to Android 9, I have an issue with information about the track playing not displaying on my screen. The issue happens in Spotify and Pandora. All it says is Bluetooth, Unknown Artist, Unknown Album for every song played. (This will make you crazy by the way) You are also unable to go forward and backward from song to song using the handlebar control. Verizon even swapped my phone, no help. I went to the dealer, and found out the on all the older bikes, and new new models without the GTS touch screen radio, the same issue occurred. On the new GTS radios, the phone works fine. The tech talked to Harley and they tried a factory reset. The handlebar backward/forward controls seem to work now, but still no track info, just the perpetual "Bluetooth" message. My tech suggested waiting to see if HD upgrades their software and warned me the aftermarket head units are not waterproof and he has seen several failed units. Other than that I have called HD, made the complaint, and no action from them. One guy nicely told me he didn't think there was any more they would do.... Great answer, eh?

Clearly its a problem with the older software on Harleys radios. My work IPhone functions fine, and my son's Android 4.0 phone works as well. I am a desperate man and about to buy a new head unit, but I thought I would reach out in case someone knows what might work to fix this. (other than a new phone!) Any ideas would be gratefully accepted.

Many thanks, all.
 

·
Registered
Joined
·
405 Posts
It may not be with Boom. I worked for a Verizon retailer for a while and we would see the issue pretty regularly after android updates. IOS 10 did the same for the iPhone users with Chrysler and Jeep vehicles. The issue was ultimately resolved with future iOS or Android updates.


Sent from my iPhone using Tapatalk
 
1 - 2 of 2 Posts
Top