Road Glide banner

1 - 7 of 7 Posts

·
Registered
Joined
·
151 Posts
Discussion Starter #1
Need a little help with a stereo issue,
My LEFT speaker crackles only when the bike is running, not when in AUX, this started a couple of days ago.

15 RG,
I have Kappa's & Cerwin Vega B52 W/ stock head unit.

This is what I have tried.
-Checked for loose connections, Stereo/Amp/Speakers(none)
-Swapped L - R speakers, (left still crackles)
-Check battery ground
-Checked plug wires

Is it possible the Head unit is NFG??

Thanxs.
 

·
Registered
Joined
·
1,743 Posts
Hey Colin, I just wanted to make sure I understood............

It's a crackle, not a hum, buzz and only when the bike is running?
 

·
Registered
Joined
·
151 Posts
Discussion Starter #3
Hey Colin, I just wanted to make sure I understood............

It's a crackle, not a hum, buzz and only when the bike is running?
definitely a crackling, speaker cuts right out, ya, only when running.

I took the fairing off today and tried moving wiring and could not replicate the sound, I swapped the L to R on the BT355 to see if the sound follows the swap??
when it happens I am going to see if it starts at a certain RPM??

Thanxs
Colin
 

·
Registered
Joined
·
212 Posts
I had the exact same issue with my bike, with the exact same setup. It was the amp. I checked and double checked everything. Drove me nuts. Only did it with the vibration of the bike.
Luckily the amp isn't stupid expensive. I bought a new one, and now it's pushing a pair of 602s. It really is a good little amp.
 

·
Registered
Joined
·
151 Posts
Discussion Starter #6 (Edited)
I had the exact same issue with my bike, with the exact same setup. It was the amp. I checked and double checked everything. Drove me nuts. Only did it with the vibration of the bike.
Luckily the amp isn't stupid expensive. I bought a new one, and now it's pushing a pair of 602s. It really is a good little amp.
okay,
Thanks Dice.
was drive me a little nuts also trying to track it down.

I have had the amp 13 months, 1 month out of warranty :mad:

Cheers
Colin


edit,
I pulled the amp and no more crackling from left speaker.

Thanxs for the heads up Dice.

Colin
 

·
Registered
Joined
·
151 Posts
Discussion Starter #7
update:

Cerwin Vega refused to do anything about the amp being 1 month out of warranty (my bike sits parked over 6 months a year (Winter))
So I called Amazon to see if they could help as I did purchase from them, they called Cerwin Vega & got the same answer as me (1 month out of warranty bla bla) the guy at Amazon was really good,he talked with supervisors for a bit & refunded me minus a re-stocking fee ($25), says that's the only way he could do it, now that is GREAT customer service.

I wont deal with CV any longer, I really liked the amp but obviously their customer service is lacking.

​​​​​​​Colin*
 
1 - 7 of 7 Posts
Top