Road Glide banner

1 - 10 of 10 Posts

·
Registered
Joined
·
165 Posts
Discussion Starter #1
Any body else havin problems with their voltage regulator? I am needing another after mine going bad last weekend. I already have the recalled regulator installed by the dealer 2 years ago now I need one again.....
 

·
Registered
Joined
·
855 Posts
Right now I'm overcharging, undercharging but running 14v most of the time, of course every time I've brought it in, they've tested it and said everything is running fine. Ugh
 

·
Registered
Joined
·
654 Posts
What are the symptoms of a a crapped regulator. For example "it is charging at 14v most of the time. Does your voltage decrease at idle? Mine goes down to 13v at idle after the bike is warmed up, but runs at 14v when riding.
 

·
Registered
Joined
·
8 Posts
yes my 2011 went from 14 to 12 volts and already did the recall so took it in they suspected another bad regulator but after 1/2 hour they said the stator was bad they replaced it and then said o and the regulator was also bad what a joke
 

·
Registered
Joined
·
134 Posts
I replaced mine with aftermarket and working great.. My original started with overcharging, then undercharging, then working fine.
 

·
Registered
Joined
·
2,266 Posts
What are the symptoms of a a crapped regulator. For example "it is charging at 14v most of the time. Does your voltage decrease at idle? Mine goes down to 13v at idle after the bike is warmed up, but runs at 14v when riding.
A couple of symptoms I noticed when mine started to crap out is the voltage meter steadily decreased down to 10v, each time I turned it on it started harder and slower. My check engine and battery light came on. While riding the volts would not go back up to the 13-14v like it should be indicating.

Those were the things I noticed when it crapped out/started to crap out.

....and of course I did the test to find out exactly what it was. replaced it about 2 years ago and it's been fine. BTW, this is my 3rd regulator. 1st one replaced under warranty.
 

·
Registered
Joined
·
165 Posts
Discussion Starter #7
Well, on mine the voltage would drop for a while then return to a normal 14.5 volts. It did this for about 3months or about 1500 miles then it kept doing it more often til it died completelynd ran my battery down
 

·
Registered
Joined
·
1,034 Posts
I had mine replaced with the CompuFire 40 amp 3-phase charging system. Best money spent on the old hog!

 

·
Registered
Joined
·
654 Posts
Is regulator replacement a simple unbolt, plug and play?
 

·
Registered
Joined
·
217 Posts
Yes, electric cycle sales a very nice unit and cheaper than the HD one and way more solid.

Envoyé de mon GT-P5113 en utilisant Tapatalk
 
1 - 10 of 10 Posts
Top