Road Glide banner

21 - 29 of 29 Posts

·
Registered
Joined
·
3,989 Posts
I changed out my camplate and pump to the SE orange one... when my bike had a lifter issue at 500mi...Havent had any issues...


You have a TC motor correct? The TC's do not have the sumping issue like the M8's. They also don't have the fluid transfer like the M8's although a few years back I did see one TC that did.


@Hammerhandle, HD does not make a SE cam plate for the M8's and I'm not really sure it would do anything to help with the sumping issue if they did.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
22 Posts
I just got my bike back as promised from my dealer, MOCO expedited a new 114 motor top to bottom with new torque cam set and all gaskets, bolts, oil lines, and oil cooler and 1,000 mile service. My dealer and tech had to put a lot of time in on this claim with MOCO and there personal tech they had come out to the dealer and inspect the bike and motor.

All i can say is i hope this helps out someone else on any warranty issues, keep all logs and receipts and pictures and videos, but most of all. If you want to keep your warranty and you want a tuner for your bike you better stick with HD tuner until your warranty up...

They will be sending the damaged motor back MOCO to split the cases or send it to a school for techs, wasn't 100% sure of sumping or tranfering, but the scored lifter bore and scarred cylinders and the videos of me complaining of off beet clacking, ticking when warmed up and a chirping/squealing sound at cold starts.
 

·
Registered
Joined
·
428 Posts
I am aware of and I am certainly keeping Greg's clutch pushrod in mind.....I will try the free warranty fix (vent kit) next time it happens...and then go to that pushrod if need be....but it's $170 all up to Australia so I will keep it cheap for starters.

Yeah it's not great for a new bike to have a clear design fault.

Kiwidave,
Did the dealer install the primary vent kit?
 

·
Registered
Joined
·
300 Posts
I just got my bike back as promised from my dealer, MOCO expedited a new 114 motor top to bottom with new torque cam set and all gaskets, bolts, oil lines, and oil cooler and 1,000 mile service. My dealer and tech had to put a lot of time in on this claim with MOCO and there personal tech they had come out to the dealer and inspect the bike and motor.

All i can say is i hope this helps out someone else on any warranty issues, keep all logs and receipts and pictures and videos, but most of all. If you want to keep your warranty and you want a tuner for your bike you better stick with HD tuner until your warranty up...

They will be sending the damaged motor back MOCO to split the cases or send it to a school for techs, wasn't 100% sure of sumping or tranfering, but the scored lifter bore and scarred cylinders and the videos of me complaining of off beet clacking, ticking when warmed up and a chirping/squealing sound at cold starts.
Mine at cold idle on the stand will make a small chirping sound, i just assumed it was the rubber mounts because it always stops when I pick up the bike and never does it when its warm

maybe im wrong??? I have no transfer or sumping issues i know that as I have checked
 

·
Registered
Joined
·
322 Posts
Discussion Starter #25
Kiwidave,
Did the dealer install the primary vent kit?
Not yet. That kit is not being sent to Australian dealerships for another 5 weeks. But they are very happy to install as a warranty item no questions asked. I am the second customer at this dealer in line for one. The staff have been very helpful over this and I don't have any issues. Just monitoring trans oil level for another 5 weeks ;-)
 

·
Registered
Joined
·
428 Posts
Not yet. That kit is not being sent to Australian dealerships for another 5 weeks. But they are very happy to install as a warranty item no questions asked. I am the second customer at this dealer in line for one. The staff have been very helpful over this and I don't have any issues. Just monitoring trans oil level for another 5 weeks ;-)
Let us know how everything turns out. I am not buying an M8 because of this design flaw that the MOCO can't figure out.
.
 

·
Registered
Joined
·
322 Posts
Discussion Starter #27
I get that, but it appears there are 2 working fixes (H-D vent kit, MCC fatter clutch pushrod) and one of them is free under warranty and the other is less than a lobster dinner. Compare that to what we have already spent or will spend on accessories ;-)

I've lost another 6 fl oz in the 450 miles since the 1000 mile service but I'm just catching the derby cover spill and returning to the trans. No, it's not as it should be, but until the vent kit arrives it's no biggie to me and a lot less hassle than regular wrenching on my 1980 FX.

It does not affect the running of the bike. Which is awesome.
 

·
Registered
Joined
·
1,978 Posts
You have a TC motor correct? The TC's do not have the sumping issue like the M8's. They also don't have the fluid transfer like the M8's although a few years back I did see one TC that did.


@Hammerhandle, HD does not make a SE cam plate for the M8's and I'm not really sure it would do anything to help with the sumping issue if they did.


Sent from my iPhone using Tapatalk
Just an FYI, the twin cams can and do sump. They just don't run out of oil and blow up.

Most people never notice since the power isn't effected till about 4500 rpm. Usually it shows up on a dyno pull, or after a high pressure spring is installed with an oem pump. I've seen a few that wouldn't dead rev past 4000 rpm.
 

·
Registered
Joined
·
3,989 Posts
Just an FYI, the twin cams can and do sump. They just don't run out of oil and blow up.

Most people never notice since the power isn't effected till about 4500 rpm. Usually it shows up on a dyno pull, or after a high pressure spring is installed with an oem pump. I've seen a few that wouldn't dead rev past 4000 rpm.

Yes I have actually heard of this but have never seen it myself. But again maybe never noticed one that did like you say. Might try and check a few more of them to see what I find.
 
21 - 29 of 29 Posts
Top