Road Glide banner
1 - 5 of 5 Posts

·
Registered
Joined
·
171 Posts
Discussion Starter · #1 · (Edited)
Just got done installing woods 222 cams.installed red shift cam tensioners with a axtell oil bypass valve,fuel moto push rods and ss lifters.fuel moto sent a dyno tune,great service from them.inside cam tensioner was spotless(40,000 miles)but the primary shoe was worn just on one end.anyway 200 miles so far and I love my bike,like everybody else,should of done it sooner.alot less engine tapping noise and oil pressure way up.going down the road and at idle.10-15 psi more,oil temp staying around 230,air temp 92-96 f, going 60-75 mph..going to get it tuned on Saturday just to tweek the fuel moto tune.
 

·
Registered
Joined
·
2,001 Posts
Installed the bypass this past winter when installing cams,they do work.
 

·
Registered
Joined
·
171 Posts
Discussion Starter · #3 ·
got it tuned today.99hp-105 torque:D
 

·
Registered
Joined
·
1,560 Posts
So are you showing 10-15 at idle and 40-45 at cruise? After my install of Drago 580 cams with stock oil spring I'm showing 5-10 at idle and 30 at cruise
 

·
Registered
Joined
·
171 Posts
Discussion Starter · #5 ·
Counting each line on guage as 2,on initial start oil pressure is 32 ,within 2 minutes it goes to 20-22 and stays until hot 230 oil temp,then goes to 16-18 at idle.at cold cruse initialy goes to 54-56,then when hot at 3000 rpm it's 48-50.I'M using mobil 1 since. 2 oil change right now at 41,430.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top