Road Glide banner

1 - 7 of 7 Posts
C

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Hello ,, everyone ,, just registered in here ,, been ridin last 22 yrs ,, i have a 74 shovel,, 97 dyna ,, and just got a 1999 road glide do those fairings ever spoil ya ,, im in Newfoundland ,, question for ya ,, lst night well out with the warden i had on the acces lights and they blew the 15 amp fuse in under the seat ,, is this a common thing that ppl encounter or what ,, it seems the more options the more problems ,, anything in particuar to check for Thanks Dave
 

·
Super Moderator
Joined
·
4,274 Posts
welcome mate, don't think it's common but there are some people here who can answer it better than I. Hopefully they'll chime in.

Welcome to the darkside :)
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Thanks for the welcome ,, i just went and picked up another fuse to see if it was a bad fuse .... Not llikely it blew right away ,,,, all other lights work stereo everything what the hell did i get myself into :confused: before i start go into it any obvious places you check Thanks
 

·
Registered
Joined
·
1,634 Posts
Accessory lights? Extra lights above and beyond the factory lights? If so, sounds like a grounding issue. Or the fuse can't handle the extra load from the lights. I'd say try a 20 amp fuse, but that may lead to melted wires if it is a ground issue.
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #5
yEah there fog lights i believe i dint realize they didnt come witout them ill give ya a pic later Thanks man il check for ground and burrs
 

·
Registered
Joined
·
2,324 Posts
+1 Ground issue. If they're add-on lights, can you just re-run the circuit using existing wiring? You'll likely uncover the problem if you do.

Welcome to the shark frenzy!
 
1 - 7 of 7 Posts
Top