Road Glide banner

1 - 16 of 16 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter #1
Is there a way to undo a upgrade on the new 15. I had my radio flashed awhile back to allow for amp and speakers. All sounded killer. Just did the new down load and lost about 80 percent of my volume now. Now I am not happy lol. Help I need to have my tunes back. Getting ready to leave on a five day road trip in a few days and was hoping for tunes. I can't even here it hardly with the bike running
 

·
Registered
Joined
·
7,034 Posts
I still have the 1.18.2 iso file in a folder, I can try and send it to you on an email attachment or if you have another suggestion. Not sure if one can download an older version after installing the new version, but do not see why not.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #3
Thanks that would be great. I think you would have to zip the file but no idea how to do that. Also do you think that it would install that version with the new one already downloaded? Anyone else out there having issue. Just got back from a ride. Can't hear anything and it keeps cutting out so mad at this. Driving me crazy and insane. I bought this bike mainly for the tunes.
 

·
Registered
Joined
·
5,203 Posts
Thanks that would be great. I think you would have to zip the file but no idea how to do that. Also do you think that it would install that version with the new one already downloaded? Anyone else out there having issue. Just got back from a ride. Can't hear anything and it keeps cutting out so mad at this. Driving me crazy and insane. I bought this bike mainly for the tunes.
I posted in the other thread. Try reinstalling it. It may have skipped a few items on the update.
 

·
Registered
Joined
·
7,034 Posts
Thanks that would be great. I think you would have to zip the file but no idea how to do that. Also do you think that it would install that version with the new one already downloaded? Anyone else out there having issue. Just got back from a ride. Can't hear anything and it keeps cutting out so mad at this. Driving me crazy and insane. I bought this bike mainly for the tunes.
I compressed the file, but it is still too large to be attached to an email. As Ohiobellboy suggested, you might try re-installing the update. I have an aftermarket AMP with a Flash done and no issues after the updated download.
 

·
Registered
Joined
·
8,571 Posts
I wonder if your high pass filter got turned on some how ??
 

·
Registered
Joined
·
8,571 Posts
Not sure what that is or how to check. Imam just sick right now about this. Lol
Take it back to the dealership, let them fix it.
 

·
JMJOHN
Joined
·
1,002 Posts
buddy75 ,,,,,

that is exactly what you WANT ,,,,,,,, now increase the input gains on whatever amp you are using to compensate for the loss of signal from the Harley radio after the flash ,,,,,,,
 

·
Registered
Joined
·
51 Posts
Discussion Starter #12
Yes I understand that volume and the gains on the amp but that will only fix the sound. Radio still cutting in and out and other times takes for ever to reboot after start up.
 

·
Registered
Joined
·
1,743 Posts
I have a public FTP server where I can host radio firmwares. If you have a firmware you want to share or archive send me a PM and I'll provide information.

The only thing you need is the file and a FTP client.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #14
Have it in at the dealer now. Ran some test and they are saying everything is fine. Harley mec take her for a ride and says yep there is a issue but there computer won't pick it up. Gets on the horn with another head office place called deely and they are now looking into. Be a few days I am told.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #15
So little update dealer was he'll bent it was the amp. So I take it home and take out the amp same problem. However I find notice every time my radio kicks out or acts up mt icon for information keeps coming up on corner of my screen. No idea what that means but that's what it is doing. Dealer says it not showing any codes. No idea what to do now still at dealer but supposed to leave for Laconia in a few days. No to pleased right now and super stressed. This was my first trip with the new bride and was crazy pumped to go
 

·
JMJOHN
Joined
·
1,002 Posts
Buddy ,,,,,,

we are set up now at Laconia HD in Meredith NH ,,, we have a good arrangement with the dealer here to make sure that the Harley radios get flashed properly for the best performance ,,,,,,

I am also seeing posts over on HD-Forums by Biketronics, advising these same J&M/Harley radio flash instructions ,,, so evidently THEY have also tried them with favorable results ,,,,

easy to follow ,, the J&M/Harley radio flash instructions are here http://www.jmcorp.com/pdf/HarleyRadioFlashROKKER-PerformEXTREME--04-02-2015.pdf ,,,,
 
1 - 16 of 16 Posts
Top