Road Glide banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
my Road glides loosing power below 3k rpm.engines not making any noise
above 4k rpm rocker boxes chattering.with work schedule havent taking it apart yet.whondering if anyone has had similar problems going to tear bike apart next weekend.thinking cams ? havent done compresion leak down test yet
 

·
Registered
Joined
·
7,261 Posts
Check for codes first. maybe in limp mode? Check your tuner to make sure that's running like it's supposed to be
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
thanks for the imfo ill check that
 

·
Registered
Joined
·
6,625 Posts
If your bike is running over 1800 rpm then it is NOT in LIMP MODE. Limp mode shuts down the TCA so you only have enough power to pull the bike off the road to a safe location, simply put you have no throttle to speak of.
Do check for DTC,s first it is always a good place to start.
If there are no DTC,s and you have a aftermarket tuner try disconnecting the tuner and see if performance changes.
Do a compression check, and inspect your spark plugs and plug wires at the same time.
Check for intake leaks.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
no codes tried to test ride yesterday.to check map and tune snapped drive belt
i dont have time to check bike.i towed it to performance shop that replaced back tire 2 weeks ago.there gonna check engine and tune compression test and
cams .ill post the final outcome soon .
 
1 - 6 of 6 Posts
Top