Road Glide banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,011 Posts
Discussion Starter #1
I have a 2015 Road Glide Special and have been running a Biketronics Bt4180 with just fairing speakers hooked up. When I installed my BT equipment, I hooked up the rear line leveler (BT355) and ran speaker wires for future upgrade.

Well I just got lowers, installed the lower speakers, turned on the bike and there was no music coming from the new lowers. I can hear a faint white noise coming from them, and I even verified this by unplugging/plugging the speaker.

I pulled my fairing apart to check that all connections were solid and was hooked up right. It all looked right to me, and I knew the fairing speakers were working great, so I decided to swap the coax connections on the line levelers. Well then I had sound to the lowers and the white noise to the fairing speaks. I switched it back and buttoned everything up.

Could my LL be busted? Am I missing a step?
 

·
Registered
Joined
·
721 Posts
I am not an expert, but it seems you need to flash the boom audio (e.g. to change from 2 to 4 speakers in its coinfig). As far as I now, it can only be done by an HD dealer. Probably there are other solutions without flashing it, but I don't know them. Good luck.
 

·
Registered
Joined
·
1,671 Posts
I am not an expert, but it seems you need to flash the boom audio (e.g. to change from 2 to 4 speakers in its coinfig). As far as I now, it can only be done by an HD dealer. Probably there are other solutions without flashing it, but I don't know them. Good luck.
Im with Rubimad....the 6.5 has to have the rears enabled with the flash...The other option, especially if the "rear" sound to the lowers isnt pushing like you want is to consider bridging the amp and running all 4 off 2 channels..again, I have no idea if you can do that with that amp, or if you have the right speakers to do it with..Good Luck!!! Ride safe!!
 

·
Registered
Joined
·
753 Posts
+3 has to be flashed OR split the signal from the front line leveler to both F and R inputs of amp using RCA Y connectors. You won’t have fade but will get you 4 channels and you really don’t need fade for lowers anyways. Be aware some dealers are giving people grief about flashing aftermarket systems.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,027 Posts
Do what @roadie13 suggests by splitting the signal. At least that is what I would do. I am running your same set up except with the 2180 amp and I just bridged it. You are going to dig the new noise your bike makes running four speakers. I had heard not too long ago, at least around these parts, that dealers are steering away from flashing infotainments unless it's for the Boom installations. Good luck, let us know how you prevail.
 

·
Registered
Joined
·
1,011 Posts
Discussion Starter #7
Thanks for all the help and suggestions guys. For the sake of time and cost, I just ran out and picked up a couple RCA Y splitters and got everything working in no time! Went for a short ride with some buddies yesterday, and everything sounded good! Where I noticed it most was when I was riding with my face shield closed/ The wind was blocked, but the sound seemed to penetrate clearer because of that. With just the fairing speakers, I did not have that same experience.

If I ever got the notion to add TP pods, I can go get the dealer flash.
 

·
Registered
Joined
·
242 Posts
This helped me out as well since I have the speaker pods and lowers with no speakers (yet)... I was doing research myself and came to the same conclusion that the others came to. I simply haven't had time to actually finish it. You verified my research. Appreciate it...

Sent from my SAMSUNG-SM-G935A using Tapatalk
 
1 - 8 of 8 Posts
Top