Road Glide banner

1 - 15 of 15 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1 (Edited)
Just installed HD Boom saddlebag lid speakers on 13 FLTRX should they be working, i've read yes i've read no I know the fade won't work without dealer upgrade, the owners manual said it's not equiped. So does the dealer also turn on the other 2 channels? Parts guy says yes, i just wanted to ask you guys, so i can put it back together. Thanks

I should add that I also put in the Boom amp with the overlay harness.
 

·
Registered
Joined
·
8,620 Posts
No. The rear speaker out put is on from the getgo. The only thing the dealer will do is flash the cpu so you will have fader control.

I am assuming your riding a Custom and not a ultra. The ultra should already have the fader.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #3 (Edited)
I don't know what I did wrong then, I followed the install intsructions to the letter, and rechecked it. Yes it's a Custom.:confused:




Just talked to parts guy said software in my bike is for only 2 channel, with the Boom.
Some other systems you may not have to do it I don't know, we shall find out. When ever it quits snowing.
 

·
Registered
Joined
·
39 Posts
hmm.... was it a plug and play setup? (just asking cause i do not know). re check you're rear pin outs again to make sure you have the correct leads. they will be:
pin 1 - right rear +
pin 2 - left rear +
pin 24 - right rear -
pin 25 - left rear -
 

·
Registered
Joined
·
363 Posts
Like bronzerx7 says, make sure the speakers are plugged into the right pins. It's the output on the right side when looking at the back of the radio.

A good thread about this topic:

http://www.roadglide.org/showthread.php?t=30549&highlight=Rear+speaker

Are you running an amp? If so, make sure there's power to the amp. If not, check your fuse and your ground. Most amps have a power light that indicates its working.
 

·
Registered
Joined
·
8,620 Posts
The plugs coming off the head set are different on the Custom and the Ultra. I was talking about the head set only putting out rear power. You will need to buy the four channel plug or tap into the pins like these guys are talking about.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #7
I have the boom amp and the non-ultra overlay harness which has the 35 pin connector on it, the 35 pin has 4 wires coming off it that get put into the ?? pin connector on the amp, I did that and rechecked it. I put the bike back together on what my parts guy told me " it needs to be enabled on my custom" so I'll find out when I get up there, It maybe a few weeks yet, it will drive me nuts.
 

·
Registered
Joined
·
163 Posts
When I had the Boom setup I had 2 sets of instructions. First set was to wire for 2 channel and the second set was to wire for the 4 channel (which my dealer said was a different harness). I bought it and wired up that way but only had them for about 2 weeks before changing audio routes. When wiring up for the 4 channel I had to take some pins out of the factory harness and swap into other harnesses. I think I had to do that on 4 or 8 wires. I bought it and wired up that way but only had them for about 2 weeks before changing audio routes. Those were suppose to be to make the radio have the rear speaker outputs.

I have done 3 street glides in the past month for the Boom speakers and had no problems with them, but they didnt have an amp. So idk if the extra harness that I had would fix your problem or not.
 

·
Registered
Joined
·
363 Posts
I have the boom amp and the non-ultra overlay harness which has the 35 pin connector on it, the 35 pin has 4 wires coming off it that get put into the ?? pin connector on the amp, I did that and rechecked it. I put the bike back together on what my parts guy told me " it needs to be enabled on my custom" so I'll find out when I get up there, It maybe a few weeks yet, it will drive me nuts.
Not sure what needs to be "enabled" other than the fade control.

As for your amp, there should be inputs and outputs. The inputs are where the wires go from HK Radio. The out puts go to speakers. I'm not familiar with the boom set up, but all amps are pretty much the same.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
8,620 Posts
Not sure what needs to be "enabled" other than the fade control.

As for your amp, there should be inputs and outputs. The inputs are where the wires go from HK Radio. The out puts go to speakers. I'm not familiar with the boom set up, but all amps are pretty much the same.


Sent from Motorcycle.com Free App
His parts guy got him bull shitted. Let him spend his cash.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #11 (Edited)
I'm going to review my instructions yet again, I didn't move any wires from the stock harness, from what I read the wires that came out of the stock harness went to the amp, the same holes that my overlay harness plugged into. I was told big gary "no charge for upgrade" if it is wrong I'll fix it.


It's not the non ultra overlay harness, it's the radio harness #69200106, the wires you would pull from the 35 pin #'s 1,2,24,25 get plugged into my amp plug. Didn't have a 35 pin it's on the radio harness, 4 wires off that go to the same holes in the amp plug. I did it. The only thing that may do it is the fade control must be enabled for it to power the rear speakers, like if the fade was set to 100% front???
 

·
Registered
Joined
·
73 Posts
Discussion Starter #12
On my way to dealer tomarrow, finally quit snowing looks like a heat wave at 50. Can't wait to have this done. I was also told by a Harley Tech that the radio had to be enabled for it to work. I also realize you can get speaker feed from other outputs on the radio but my harness doesn't use them??? We shall see. I will post results. #1, I did it right and it is just the Boom system doing things differently then other systems, or #2, I completely messed it up.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #13
Made it to the dealer yesterday, it sure was great to get out and ride. Found out one thing for sure, if you put extra speakers on a 2013 FLTRX (Roadglide custom) and you use the boom amp with the HD radio overlay harness they will NOT work until the dealer enables the radio calibration from 2 to 4 speakers thats a fact. My saddlebag speakers look good and sound good. Service did charge me but I don't care they were swamped getting bikes out of storage. The bill was $6.56.
 

·
Registered
Joined
·
1,344 Posts
$6.56? I think they made a billing error Lol

Glad it fixed and not too expensive.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #15
Yeah it was like 8 min labor plus tax, just glad it works.
 
1 - 15 of 15 Posts
Top