Road Glide banner

1 - 15 of 15 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter #1 (Edited)
Just installed JAMP 500HR06 RCR with 7.25 ROKKER XT and using HK head unit
Speakers work fine when plugged directly into OEM harness but no sound in front or rear bag speakers when connected to amp.
Amp has power and all connections appear to match instructions.
I need some help as this has me stumped.
Equipment bought new through Eastern Performance.

Any suggestions are appreciated
Steve
 

·
JMJOHN
Joined
·
1,002 Posts
Steve,,,,,,

when you turn on the ignition, what does the little light on the amp do ? ,,,,,

if nothing, please check the connection of the orange turn-on wire to the accessory circuit inside your fairing, either the orange wire in the headlight harness, or the back of the cigarette lighter ,,,,,

I will help you get this going ,,,,,,
 

·
Registered
Joined
·
135 Posts
Discussion Starter #3 (Edited)
Thanks, like to get this resolved ASAP as our ride season is very short here
Orange wire connected to orange from light harness as per instructions
Nothing hooked to cigarette lighter as instructions indicated those were for "optional" light ring which I do not have.
Green light on amp when bike turned to on.
Also are there no "gain" controls on this version of amp??
email me directly at [email protected] to expedite this please
 

·
Registered
Joined
·
135 Posts
Discussion Starter #4
Steve,,,,,,

when you turn on the ignition, what does the little light on the amp do ? ,,,,,

if nothing, please check the connection of the orange turn-on wire to the accessory circuit inside your fairing, either the orange wire in the headlight harness, or the back of the cigarette lighter ,,,,,

I will help you get this going ,,,,,,
I would like to resolve this soon please
 

·
Registered
Joined
·
275 Posts
Just checking. I had a similar issue with J&M and the only way to get it resolved was to send back the amp and have them (J&M) update the software on the amp. He claimed the problem was with my 2012 battery and that he could fix with updating the software on the amp. But now all new amps ship with this update. I basically would have to remove the amp and ship back at my expense for them to fix. I never did get it fixed....just have to start the bike a few times and sometimes I get the radio to work....others I don't. Very frustrating!

To be honest, I'm not impressed at all with the sound from this J&M stuff (250w amp and Rokkers). If I'm going to go through all the trouble to remove the fairing, ship it back, wait for them to fix it, remove fairing again, then I'm going to replace and stay far away from John and J&M products totally. I have plenty of friends that ride and I have also steered them away from J&M. Very bad experience with their products and their "customer service".

You will find many people on here that love the J&M products...just not my cup of tea!
 

·
Registered
Joined
·
135 Posts
Discussion Starter #8
Just checking. I had a similar issue with J&M and the only way to get it resolved was to send back the amp and have them (J&M) update the software on the amp. He claimed the problem was with my 2012 battery and that he could fix with updating the software on the amp. But now all new amps ship with this update. I basically would have to remove the amp and ship back at my expense for them to fix. I never did get it fixed....just have to start the bike a few times and sometimes I get the radio to work....others I don't. Very frustrating!

To be honest, I'm not impressed at all with the sound from this J&M stuff (250w amp and Rokkers). If I'm going to go through all the trouble to remove the fairing, ship it back, wait for them to fix it, remove fairing again, then I'm going to replace and stay far away from John and J&M products totally. I have plenty of friends that ride and I have also steered them away from J&M. Very bad experience with their products and their "customer service".

You will find many people on here that love the J&M products...just not my cup of tea!
Well on June 30th John said "I will help you get this going"...I have heard nothing from JM since, I could have sent it back by now. I am in Canada so it's going to take that much longer...I would at least have appreciated a response and some direction.
 

·
Registered
Joined
·
135 Posts
Discussion Starter #9
Steve,,,,,,

when you turn on the ignition, what does the little light on the amp do ? ,,,,,

if nothing, please check the connection of the orange turn-on wire to the accessory circuit inside your fairing, either the orange wire in the headlight harness, or the back of the cigarette lighter ,,,,,

I will help you get this going ,,,,,,
I need some resolution on this issue now please, it's been 9 days since any correspondence and I sent email to JM
 

·
JMJOHN
Joined
·
1,002 Posts
Platinum69 .,,,,,,

the orange wire from the amp is what turns it on ,,,,,,

assuming you have the main power wire run to the positive battery post, and the main ground wire to the frame, once the orange wire gets power, the amp will turn on ,,,,,,

do you have a test light or volt meter ??
 

·
Registered
Joined
·
135 Posts
Discussion Starter #12
Platinum69 .,,,,,,

the orange wire from the amp is what turns it on ,,,,,,

assuming you have the main power wire run to the positive battery post, and the main ground wire to the frame, once the orange wire gets power, the amp will turn on ,,,,,,

do you have a test light or volt meter ??
yes it is all connected like that and a green light on the amp when bike is turned on
yes I have a meter
 

·
JMJOHN
Joined
·
1,002 Posts
platinum69 ,,,,,,

I am stumped as to what could be connected wrong ,,,,,,

every single amp we sell is tested on the bench, with all harnesses that it will be packaged with, prior to packaging, amp gains are all set etc ,,,,,,

sound goes from the speaker wires coming out of the Harley radio, right into the J&M custom RCA input harness, into the ROKKER XT amp, then out of the amp to the speakers ,,,,,

all plug n play as you know, not really a rocket-science type deal ,,,,,,

get back to me direct at [email protected] ,,,,,,
 
1 - 15 of 15 Posts
Top