Road Glide banner

1 - 12 of 12 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #1
Let me start by saying that this is my first Harley.
13 RGC -
I dont recall this happening when I got it so Im curios if its just wear or something came loose...

Whenever I shift Gears I hear a slight clank when I pull the Clutch lever in... I hear a clank when I throw into gear (any - and I think this part is normal) but also hear a slight clank when I release the clutch - BTW i hear the clank on pull and release even if I don't switch gears... Also...
If I'm cruising .. and I release the throttle I hear a clank and it i hit the throttle to continue the cruise after real ease.. I hear a clank...
Dealer stated it was normal ,... stated "compensator in Primary" would have a slight lag so when "Gears" engage it will male the noise..
I dont recall hearing till after they did 500 mile tune and went to Synthetic...
BTW.. it all seems to be coming from inside the Primary...
Anyone have any Ideas... Could it be something Got loose?

Appreciate any feedbacks
 

·
Registered
Joined
·
672 Posts
My 07 does the same thing. It annoys the hell out of me but I think its normal. Ill let someone else confirm this though.
 

·
Registered
Joined
·
188 Posts
Just had mine in fr that same noise but it was all the time. My compensator bolt came loose and f'd up the bearing in there. Thank god for extended warranty. Total bill would have been 1100.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
5,189 Posts
I am by no means a wrench, but IMO you could call bullshit on your dealer. It's not normal IMO. Again I am not a wrench, but I would get a second opinion from either another dealer or a reputable independent.

Rowdy
 

·
Registered
Joined
·
115 Posts
I agree with the BS call I have a 13 RGU and have no Clanks cept sometimes when it goes into gear that would be normal but not when you engage the clutch. However I am also no wrench but I did stay at a Holiday Inn Express.:D
 

·
Administrator
Joined
·
12,480 Posts
I agree with Rowdy and bombdog, I say take it back to the dealer, or have a different dealer check it.

Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
77 Posts
Discussion Starter #7
Thanks all for the Input... have appointment for later this week!!
 

·
Registered
Joined
·
158 Posts

·
Registered
Joined
·
836 Posts
I would pull your primary cover and check the clutch adjustment. Loosen your clutch cable. Pull the cover. Loosen the jam nut in there using a alan wrench and an open socket. Then tight the alan just until it touches and meets resistance then loosen a 3/4 turn. Tighten the jam nut back up and replace primary and readjust clutch lever. See if this helps. Plenty of vids on the you tube if you don't understand what i just said.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
672 Posts
So?? Verdict is??

I went and adjusted the clutch on mine and around town it seems better but havent gotten weather to hit the highway yet.
 

·
Registered
Joined
·
2 Posts
Same Primary Noises

I'm having the same primary noise issues with my 2013 RGU (2000 miles). Mine also semed to become more noticeable after the 1K mile service using Syn 3 in all 3 holes. Brought it up to the dealer twice, and each time they could not (would not?) find a problem. Last time they adjusted the clutch free play. No joy. There's lots of noise in a Harley, but I don't recall my 06 Sporty or 09 Dyna making this much racket. Nearest I can explain it is that it sounds like a car with a bad universal joint. Add throttle in upper gears and it "clunks". Back off the throttle and it "clunks". After warm-up every time I hit a bump it sounds like the primary chain is banging on the housing, and after a hundred mile ride, there'a a rattle in the primary when I let out the clutch in nuetral. Goes away when I pull in the clutch. Sounds like a Model T. Can't wait to hear what your dealer experience is. Since I have the ESP I guess I'll just ride it till there's a failure.
 
1 - 12 of 12 Posts
Top