Road Glide banner

1 - 2 of 2 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter #1
Hey guys, I am a novice wrench turning person, so please feel free to chime in with what you all have experienced.

I am looking at getting a oil pressure test kit https://www.harborfreight.com/engine-oil-pressure-test-kit-62621.html, my oil light is flickering and I am leaning more towards a loose wire or possible pinched some where, how ever better safe than sorry so I want to check the oil pressure.

Yes I have changed the sender unit, and for a bit everything was fine :grin:, until light came back flickering again :frown:. The oil pressure gauge looks to read as normal, no higher than 36 while moving and no less than 28-30 while idling, when it's hot it will drop to 10-15 lbs, how ever the fact I am not hearing any abnormal noise (lifters) while riding tells me the oil pump is fine, but once again going to check the pressure to make sure.

So question is does anyone have this test kit?

Has anyone had this issue before and what was your fix?

I have 2013 RGC 26-27K miles, Cobra Swept Exhaust, Kuryakyn Mach air 2 breather, SE254 cams, PV tuner (has been dynoed).
 

·
Registered
Joined
·
155 Posts
Discussion Starter #2
lol ok, I'll take that as a no to both questions, just an update for everyone I have noticed that when I actually put pressure on the front of the fairing the light goes out, which tells me there is a loose connection, so I will be taking the front fairing off and looking for the connection.
 
1 - 2 of 2 Posts
Top