Road Glide banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi all, have a pcv installed on my 10 ultra with stage one download, screamin eagle a/c and mgs slip ons.
Happy with everything except the starting issues.
as told i hit start before the cel light goes out and that always works when bike is warm. however when cold it is hit or miss. sometimes waiting for the light to go out works, sometimes bike turns over way too many times. sometimes you get starter noise included. if you stop and start all over from main switch on to stop/run switch on and hit starter she will usually go.
its becoming concerning and embarrassing at times.
really considering going back to the fl-vied. just so she starts properly.
guys on the forum seem to suggest the pcv is a much better way to go verses the vied but is it really?
anyone else with these issues that have bailed on the pcv
thanks ken, canada
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
Hi all, have a pcv installed on my 10 ultra with stage one download, screamin eagle a/c and mgs slip ons.
Happy with everything except the starting issues.
as told i hit start before the cel light goes out and that always works when bike is warm. however when cold it is hit or miss. sometimes waiting for the light to go out works, sometimes bike turns over way too many times. sometimes you get starter noise included. if you stop and start all over from main switch on to stop/run switch on and hit starter she will usually go.
its becoming concerning and embarrassing at times.
really considering going back to the fl-vied. just so she starts properly.
guys on the forum seem to suggest the pcv is a much better way to go verses the vied but is it really?
anyone else with these issues that have bailed on the pcv
thanks ken, canada
Anybody?
 

·
Registered
Joined
·
2,098 Posts
Hi all, have a pcv installed on my 10 ultra with stage one download, screamin eagle a/c and mgs slip ons.

Happy with everything except the starting issues.

as told i hit start before the cel light goes out and that always works when bike is warm. however when cold it is hit or miss. sometimes waiting for the light to go out works, sometimes bike turns over way too many times. sometimes you get starter noise included. if you stop and start all over from main switch on to stop/run switch on and hit starter she will usually go.

its becoming concerning and embarrassing at times.

really considering going back to the fl-vied. just so she starts properly.

guys on the forum seem to suggest the pcv is a much better way to go verses the vied but is it really?

anyone else with these issues that have bailed on the pcv

thanks ken, canada

I don't know what the vied is, but this is a common issue with engine mods on the older bikes. My problems ('13 FLTRU) started with the Stage IV mod with screaming eagle race tuner. I ended up having the compensator and the starter upgraded. Good luck.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
462 Posts
?? Not sure about the sequence you are using for start up but it could have a part to play. Ignition to on, press run (don't wait for fuel pump prime to stop) immediately hit start. Also there is a fuel setting for start-up in the PCV utility software. You might want to see how your's is set up. Might want to remove ECM/PCV connection to check pins to ensure all are straight and reattach connection after applying liberal amount of dialectic grease.
 
1 - 4 of 4 Posts
Top