Road Glide banner

1 - 17 of 17 Posts

·
Registered
Joined
·
487 Posts
Discussion Starter #1
Just installed Custom Dynamics Pro beam Front/Rear LED's on my 2018 Road glide special.

The good...
Signals/brake lights are VERY bright. To the point you would have to have your eyes shut not to see them. :grin::grin:

The bad...
One of the rear lights had a ground wire that was not connected so my left rear running /turn/brake light did not come on. :surprise: NOT impressed for a $110.00 set of rear lights. So quick action with a tiny bit of electric solder and the light works fine. No problem, it works and I will toss it up to a fluke.

Test it in the shop and the probeams come on and blink at a normal rate of speed. However even though the lights themselves are blinking at a normal rate of speed, the green turn signal indicators on my dash are blinking at 3 times the normal rate.

Any ideas? I was under the impression that you didn't need to run turn signal load equalizers with the 2018 bikes.:serious::serious::serious::serious:
 

·
Registered
Joined
·
4,820 Posts
I would give custom dynamics a call, their stuff is usually plug and play. I have used their products on many bikes with zero issues.

It's got to be something simple, maybe a defective part?

Keep us posted!
 

·
Registered
Joined
·
534 Posts
I'm running the old school Custom Dynamics front and rear on my 17, took them out of my 09 before I traded it in. Working great so far. One of our other RGS riders had the new PB, no issues so far, but, then again he's a bit of a slow poke so I really don't see the back of his bike that often! I agree, you should contact CD, they have a decent customer service department.
 

·
Registered
Joined
·
1,605 Posts
I was under the impression that you didn't need to run turn signal load equalizers with the 2018 bikes.:serious::serious::serious::serious:
installed same set on my '18 FLTRX and no problems.

did you clean out the dielectric grease as per instructions?
did you run flashers for a few minutes?

i've heard their customer service is very responsive so should be able to cure with a phone call. let us know how it works out.
 

·
Registered
Joined
·
1,053 Posts
I just put the same pro beams on my '15 FLTRXS and I have no issues. They are incredibly bright!
 

·
Registered
Joined
·
1,537 Posts
This seems to fix most. My 15 RGS it didn't fix it. Even after 5 min. But it doesn't bother me because the actual turn signal is fine to cars.

Sent from my SM-G930V using Tapatalk
 

·
Registered
Joined
·
435 Posts
Just installed Custom Dynamics Pro beam Front/Rear LED's on my 2018 Road glide special.

The good...
Signals/brake lights are VERY bright. To the point you would have to have your eyes shut not to see them. :grin::grin:

The bad...
One of the rear lights had a ground wire that was not connected so my left rear running /turn/brake light did not come on. :surprise: NOT impressed for a $110.00 set of rear lights. So quick action with a tiny bit of electric solder and the light works fine. No problem, it works and I will toss it up to a fluke.

Test it in the shop and the probeams come on and blink at a normal rate of speed. However even though the lights themselves are blinking at a normal rate of speed, the green turn signal indicators on my dash are blinking at 3 times the normal rate.

Any ideas? I was under the impression that you didn't need to run turn signal load equalizers with the 2018 bikes.:serious::serious::serious::serious:
You don't need a load equalizer, just turn on the hazards for 3 to 5 minutes and let the computer sync them. Had to do this on my 16 as well. I should have read the whole thread first before chiming in. Doing this synced mine perfectly, if not CD has great customer service give them a call.
 

·
Registered
Joined
·
487 Posts
Discussion Starter #12 (Edited)
Ok, so to be fair to the company I will say this. The lights are very bright, look great, and are IMO well worth the money. It would have been nice if I didn't have to have to solder on a brand new light but, as I stated above I will toss that up to a fluke. They seem to be a stand up company from what everyone says.

I will contact them just so that they are aware of the problem I had, maybe they will do a little better quality control . I see no need to send it back as it is working fine now.

Anyways, here are some pics and I'm very happy with the end results.
 

·
Registered
Joined
·
450 Posts
CD has excellent customer service. I had a 3 year old light go out and had a new one 48 hours later. They even stood behind another manufacturers product when I couldn't get them to respond just because I purchased it from them.
 

·
Registered
Joined
·
3,243 Posts
I'm blind! Maybe a warning :) They look great
 
  • Like
Reactions: BigBlockBobby
1 - 17 of 17 Posts
Top