Road Glide banner

1 - 20 of 20 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1 (Edited)
Anybody else experience problem starting their bike during ride, sounds foolish but a couple of times this past year, after stopping for gas or a rest, when I pushed the start button there was nothing, after couple of tries the bike fires up no issues. This has happened a hand full of times. No security on the bike.

I have checked all connections and cleaned battery posts, does not seem to have loose connections.

Bike is a 2012 RG

Any suggestions or anybody else having this problem, Thanks
 

·
Registered
Joined
·
8,831 Posts
Check the starter relay connection. A little dielectric grease on the tabs will help.
 

·
Registered
Joined
·
34 Posts
I have a 2012 RG Ultra and have been experiencing that same problem since new. Only about 6 times in the first yr. none the second yr.and then once the end of last yr. Alway happens after just a quick stop ,fuel stop, stop for road construction, things like that. Same as you I have checked all connections, look fine. It has never failed to start after a couple hits on the starter button. I have kind of come to live with it. Sorry I couldn't be any help.
TT
 

·
Registered
Joined
·
7,261 Posts
Does it crank over but not start or is it not even turning over?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6 (Edited)
No cranking just dead,not even a click,forgot to mention that no security.
 

·
Registered
Joined
·
34 Posts
Not to hijack his thread, but mine doesn't crank over. I turn the key on and everything looks normal, headlights come on,all dash lights on, but when I hit the starter switch it's dead. Just like someone turned the run /stop switch to the stop position. Hit the starter switch a couple of times and she fires right up.
TT
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8 (Edited)
No problem, hate to say it but glad to hear it is not just me.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
Thanks for the idea.
 

·
Registered
Joined
·
7,261 Posts
No cranking just dead,not even a click,forgot to mention that no security.
Next time it happens try tapping the handle of a hammer or screwdriver on the starter while pushing and holding the start button.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
Thanks for all the ideas / suggestions
 

·
Registered
Joined
·
155 Posts
Check the starter bolts mine did that and found them loose which breaks the ground
Sounds like a ground issue. I had a similar issue a few years ago. The ground cable from the battery wasn't grounding out on the frame good.
 

·
GONE BUT NOT FORGOTTEN
Joined
·
2,338 Posts
It happened to me.... once. I was 540 miles from home headed to the Black Hills. Ignition on.... wait for the fuel pump and lights on the speedo to go out.... Hit the starter and nothing. Cycled the ignition switch, and it started right up. What a relief... it would have been a long walk ;)
 

·
Registered
Joined
·
6,625 Posts
Not really a big problem it is pretty common.
When it happens just turn the ignition off then back on wait for the engine light to go off and the bike will start.
 

·
Registered
Joined
·
2,001 Posts
This happened on my 12 a couple of times when it was new,started checking connections,when i pushed in on the relay wire that goes into the starter i felt it click,haven't had a problem since,knock on wood.
 

·
Registered
Joined
·
1 Posts
My2013 has done this several times also. I turn the key switch off and back on and usually only have to do it once to get er going.
 

·
Registered
Joined
·
19 Posts
This has happened to me on a few bikes. Pulled the control apart, cleaned and greased the start and run button connections and good to go.

Don
 

·
Registered
Joined
·
27 Posts
I had this happen to me , it kept getting worse for a while then I did the starter rebuild that's on this forum. The old contacts in the starter were a little worn but didn't look that bad, I replaced them anyway and haven't had a problem since. That was about a year and a half ago. Theres a lot of helpful info on this forum!
 
1 - 20 of 20 Posts
Top