Road Glide banner

1 - 9 of 9 Posts

·
Registered
Joined
·
483 Posts
Discussion Starter #1
Sorry folks..:(
Cant seem to find the thread where a fellow member after a monotube install was having a clunking issue..hoping you might be able to point me in the right direction....

I did the -2 drop no spacers just the 2 springs in each side...but sounds like a clunk when the front end rises or falls during a bump maybe a neck bearing adjustment? or just lose as he77?

thanks for your help

Watsondog
 

·
Registered
Joined
·
715 Posts
Mine has a little clunk too. Took it apart and could not find any problem. Had the dealer look at it and they could not help with any advice. They checked the neck and all good. I have learned to live with it and after about 17,000 miles have not gotten any worse. No wobble, drives great. I also called Progressive a couple of years ago and they were no help. I have installed the monotubes on two friends bikes and they don't clunk. Sorry, don't have a cause or cure.
 

·
Registered
Joined
·
1,135 Posts
Is it every time you hit a bump? Could it possibly be the brake lines tapping on something with all that extra slack they now have? I'm lowered 1" and hear a clunk/tap noise when I hit my front brakes for the first time pulling the bike out of the garage
 

·
Registered
Joined
·
483 Posts
Discussion Starter #6
It really only occurs on decent size bumps at slow speeds...thanks for the heads up on the cables I will ck that...I'm going to ck my neck bolt torque and if that good I'm going to deep dive and adjust swing if need be.

Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
42 Posts
You have to install the spacers that come with the mono tubes. Mine did the same thing I had to take them apart and put the spacers in. After that its been fine.
 
1 - 9 of 9 Posts
Top