Road Glide banner

1 - 7 of 7 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Ok I have installed a Rockford Fosgate PBR 300x2 w a pair of Hertz 165 HCX 6.5 in my 2015 RGS. everything went fine, I will create another post w tons of detailed pics for anyone looking to do a similar install. I take it to the HD dealer and tell them I need to flash the HU to AMP 1-off AMP 2- off and speakers 8. They tell me it's stock setting is amp 1 & 2 off and speakers 2. And my RGS only has options for 2, 4, 6. Also says that when you add an external amp you need to change it to amp 1 on. Now I wasn't standing in the shop w him when he did it but when he was done I had no sound. Which was amp 1-on amp 2-off 2 speakers. So I have a few questions that hopefully someone who has gone thru this can help with. 1- whatever flash you used do you have the remote wire hooked up ? 2- does anyone know what the stock factory settings are for amp 1 & 2 ? I read the rockford service bulletin on turning amp 1 & 2 off. But the tech said that's how it was stock. He returned the settings to stock and I have sound. Better than stock sound but vocals sound distorted at 60% volume. Any help would be greatly appreciated.
 

·
Registered
Joined
·
67 Posts
After I installed a PBR300 and Infiniti Kappas, I still had distortion at volume. I don't know the stock settings, but I printed out and had the dealer use the flash instructions in the sticky in this section titled, "Sticky: 14-15 Harley Radio FLASH Best Procedures Again!". Worked very well for me; cured the distortion problem and I have clear tunes at speed.
 

·
Registered
Joined
·
67 Posts
Yes - I do have a remote wire hookup.
 

·
Registered
Joined
·
128 Posts
After installing the same amp and Infinity speakers I had the dealer flash my stereo but the sound was flat afterwards and I had no real bass or treble control. I went back to the stock flash settings and it sounds much better to me. The reason you lost sound after the flash is because the output voltage from the stereo drops too low to turn on the amp so you have to hook up the remote wire to a switched 12v source to power the amp.
 

·
Registered
Joined
·
88 Posts
Radio flash should be Amp 1 - No, Amp 2 - No, number of speakers 4 ( it won't allow you to set to 8 unless you have a Road Glide Ultra, it goes by your vin#) by choosing 4 speakers now it will enable front/rear fader if you ever decide to add rear speakers.

Yes you will need to hook up your remote wire (it tells the amp to turn on). I tapped into the accessory outlet power on the left lower side of the fairing. ( I believe it is a purple wire)

You will also need to adjust the "gain level" as outlined in the instructions included with the amplifier. This will prevent distortion when the volume is turned up. My amp included a CD with different hz tracks. I had to transfer it to a flash drive, the plug it into the accessory audio hook up in your right glove box.

Make sure your speakers are unplugged! Play track 7 at about 70% volume and adjust the gain level as outlined in the amp instructions.
 
1 - 7 of 7 Posts
Top