Road Glide banner

1 - 13 of 13 Posts

·
Registered
Joined
·
623 Posts
Discussion Starter #1
Last week I updated my 13 by adding boom speakers, boom fairing amp and bass boosters. All went pretty well on the install. Only issue i had was snapping off one of the very thin plastic pieces that snap-fit the wiring harness, however it didn't seem to cause any problem.

Upon completing the install, everything appeared to be working fine, however there is an download available that is 'required'. I took it in to my local dealership and checked with one other. They both said the charge is half hour for doing the download. I went ahead and took it in today to have it done.

The service manager came out after a few minutes and said they couldn't do the download. He took me back there to show me why. When they hook the computer up to my bike it's, in his words, as though the radio is 'missing'. It should be showing the information on my radio but it shows nothing. With that being the case they cannot do the download. They hooked up to another bike in the shop that they had just done the same updates to and it worked as it should. They also called harley and they couldn't offer any advice.

Obviously they would be more than happy to diagnose what's going on, at $87 an hour. I'm now questioning is the amp really working or am I just hearing the upgraded speakers? Does anybody know if there is anything specific I can check to see where there may be a problem. I followed the directions and didn't have any issues. It seems if it wasn't hooked up correctly it wouldn't be working.
 

·
Registered
Joined
·
1,477 Posts
Unless I'm missing something here the download is for bikes that don't already come with rear speakers. It esentally turns on the rear channel outputs. Your signature says you have a RGU which means the rear channels are already activated.
 

·
Registered
Joined
·
623 Posts
Discussion Starter #4
The flash isn't a warranty issue because it's extras that I'm adding. I don't know exactly what the flash is supposed to do but the instructions with the bass boosters (and I think with the amp) state that a flash is necessary for it to be working optimally
 

·
Registered
Joined
·
6,572 Posts
If your upgraded audio all HD parts then all the radio flashes sould be covered.
 

·
Registered
Joined
·
82 Posts
The J1850 data line in the radio may be turned off. Have seen that before, but cannot remember how to get it back on (some hidden sub-menu)
Try Iron Cross Audio.
 

·
Registered
Joined
·
623 Posts
Discussion Starter #7
The J1850 data line in the radio may be turned off. Have seen that before, but cannot remember how to get it back on (some hidden sub-menu)
Try Iron Cross Audio.
That sounds interesting. I'll try getting with them when I have a chance. Thanks
 

·
Registered
Joined
·
209 Posts
Unless I'm missing something here the download is for bikes that don't already come with rear speakers. It esentally turns on the rear channel outputs. Your signature says you have a RGU which means the rear channels are already activated.
This is kinda sorta not correct. What the "flash" does is activate the fader. You can tell if you need the flash simply by using the left handlebar switch for bass treble, etc. If it goes to fader, you don't need to do anything. If fader is not available through that menu then you would need the flash if you so see fit. The rear outputs on the radio still work perfectly fine, you just wouldn't have fader control. On bikes that do not have the 35 pin connector (on the right of the radio looking from front) such as RGs and SGs you would need to purchase the 35 pin connector, the pins for it, and then put your wires in on pins 1,2,24,25 to have rear outputs.

Pin #1 - Right Rear +
Pin #2 - Left Rear +
Pin #24 - Right Rear -
Pin #25 - Left Rear -
 

·
Registered
Joined
·
623 Posts
Discussion Starter #9
This is kinda sorta not correct. What the "flash" does is activate the fader. You can tell if you need the flash simply by using the left handlebar switch for bass treble, etc. If it goes to fader, you don't need to do anything. If fader is not available through that menu then you would need the flash if you so see fit. The rear outputs on the radio still work perfectly fine, you just wouldn't have fader control. On bikes that do not have the 35 pin connector (on the right of the radio looking from front) such as RGs and SGs you would need to purchase the 35 pin connector, the pins for it, and then put your wires in on pins 1,2,24,25 to have rear outputs.

Pin #1 - Right Rear +
Pin #2 - Left Rear +
Pin #24 - Right Rear -
Pin #25 - Left Rear -
That was what the dealership originally said is that the download is to add the fader control. I explained to him that the fader already worked fine but the paperwork with the bass boosters, and I thought with the amp, stated that a download needed to be done. They did confirm this and found the correct download but when hooking up the computer my radio doesn't show up. I don't remember exactly what wires went where currently but the ultra does have the 35 pin connector and I followed the instructions to pull the 4 pins from one connector and add them to the harness that came with the kit.

I'm so confused lol
 

·
Registered
Joined
·
209 Posts
That was what the dealership originally said is that the download is to add the fader control. I explained to him that the fader already worked fine but the paperwork with the bass boosters, and I thought with the amp, stated that a download needed to be done. They did confirm this and found the correct download but when hooking up the computer my radio doesn't show up. I don't remember exactly what wires went where currently but the ultra does have the 35 pin connector and I followed the instructions to pull the 4 pins from one connector and add them to the harness that came with the kit.

I'm so confused lol
if your fader works and you have rear speakers, i wouldn't worry about it.
 

·
Registered
Joined
·
4,280 Posts
I explained to him that the fader already worked fine but the paperwork with the bass boosters, and I thought with the amp, stated that a download needed to be done. They did confirm this and found the correct download but when hooking up the computer my radio doesn't show up.
if your fader works and you have rear speakers, i wouldn't worry about it.
there is a different download that is supposed to be some kind of bass boost to make those bass ports actually work. nothing to do with the fader control.
 
1 - 13 of 13 Posts
Top