Road Glide banner

1 - 8 of 8 Posts

·
Registered
Joined
·
183 Posts
Discussion Starter #1
anyone know how diffacult it would be to replace my factory Radio Sound radio with a newer HK?
the radio sound just stinks, i have an 04 roady.

thanks
 

·
Registered
Joined
·
123 Posts
Sound is still gonna be the same with newer HK. Go aftermarket and you'll be glad you did. Find something with iPod controls and get a hawg wired adapter for the handlebar controls. Then you will want upgraded speakers, then an amp, then satellite radio.....this list goes on and on.
 

·
Registered
Joined
·
183 Posts
Discussion Starter #6
here's the downlow,
i boought the bike used in 12. Its an 04, (bhought someone elses mid life crisis) the bike had the rear speaker upgrade, the amp upgrade. the amp was mounted in the saddle bag...so i moved it to under the tour pak, were the instructions said it should be mounted. i started to ge alot of static in the left side speakers only. spent ALL winter checking and rewireing grounds.
im not rich nor poor, and am extreemly hard of hearing (i blame drag pipes and guns), just dont want the static which my poor hearing seems to pick up oh so well. just trying to get sounds without static noise.
dont want to spend alot of presidents on something im not really going to hear anyway.
Some one has a good deal on an HK, so was going to go with that to eliminate that the radio sucks. i do believe that the amp may be a problem, but have to start some where.
what do you think?
 

·
Registered
Joined
·
123 Posts
Try and swap your speaker outputs. If the static sound you are hearings switches sides on the bike then the amp may be the culprit. If the static stays on the same side it most likely is a bad speaker. The input signal could also cause it which may be either a wiring issue from the head unit to the amp or a bad output from the head unit.
 

·
Registered
Joined
·
183 Posts
Discussion Starter #8
Thanks,
i actually tried the swap of speakers and actually decided to do away with the amp and the rear speakers. i still get a click in the left speaker when i turn on the ignition switch and on some songs.
better off with my nightrain, no radio.
 
1 - 8 of 8 Posts
Top