Road Glide banner

1 - 8 of 8 Posts

·
Registered
Joined
·
781 Posts
Discussion Starter #1
I took out the battery. And after I was done changing it, I went for a ride. After a bit, I turned on the radio and had no sound. So, I got home and turned it off, then turned the bike back on w/o starting it, and the radio and volume came on? I did notice the avc was off. I don't know it that was the problem. Anyone have any other ideas. Now last year I did put in the JVC speakers and amp. So I did run the wires under the tank.
 

·
Registered
Joined
·
4 Posts
If you have added a amplifier, most likely there is a fuse at the battery for the amp and it may have popped, therefore no sound?
 

·
Registered
Joined
·
781 Posts
Discussion Starter #3
So, if it popped a fuse, why would the volume go on when I turn the bike off and then turn it back on w/o starting the bike?
 

·
Registered
Joined
·
4 Posts
The main ground wire from the amp may have been grounded to the battery, when changing the battery you may have hooked up the power but not the main ground. the amp will work pulling ground thru RCA cables or other means but not good enough when the bike is running...?????
 

·
Registered
Joined
·
781 Posts
Discussion Starter #5
No, my ground wire is on the frame. Looks like I'm going to have to pull the tank to see if I pinched the radio wire. Just don't know how it would work at all if I did that, but I don't know what else to do.
 

·
Registered
Joined
·
275 Posts
Did you make sure the speaker switch on the forks was in the on position?, or the wires going to the switch aren't loose?
 

·
Registered
Joined
·
781 Posts
Discussion Starter #7
I had two people on this forum ( I can't find them now to thank) that told me the same thing happened to them when they put in the J&M amp and speakers. They told me it was my battery. It needed to be replaced. I had issues with the battery over the winter, and since I had it recharged, it turned the bike over but real slow. So, I thought what the heck, buy a new battery. Probably need one anyway. Well, I haven't had a issue at all with no sound coming from my speakers since I replaced my battery. And the bike starts so fast now. So, thanks to all that gave me personal pm's and posted here. This is a great forum!
 

·
Registered
Joined
·
6,625 Posts
The AVC will affect the volume level on the radio.
 
1 - 8 of 8 Posts
Top