Road Glide banner
  • Hey Everyone! Vote for the Site Favourite BOTM winner for the year of 2022 HERE!
1 - 7 of 7 Posts

· Registered
Joined
·
131 Posts
Discussion Starter · #1 ·
Sometimes the red key light on my tach is on the entire time I ride, sometimes it off the entire time and other times it just does whatever, cant figure this thing out and neither could a guy at the dealer. Anybody know the deal??
 

· Registered
Joined
·
3,682 Posts
I bet you have a pinched wire somewhere. That key light is an indicator of electrical problems.

First place to check is your front turn signals. Do you take your outter fairing off a lot? Chances are you have a pinched wire there where the lights go into the fairing.

That was my issue when I had this problem.
 

· Registered
Joined
·
131 Posts
Discussion Starter · #5 ·
I found a post on another HD forum, one guy said his was due to him replacing his turn signal lights with LED's without a load equalizer. I have the exact same issue. I plan on getting custom dynamics LED's with the load equalizer, but that's going to have to wait for a bit. So I'm hoping this is what it is.
 

· Registered
Joined
·
538 Posts
I found a post on another HD forum, one guy said his was due to him replacing his turn signal lights with LED's without a load equalizer. I have the exact same issue. I plan on getting custom dynamics LED's with the load equalizer, but that's going to have to wait for a bit. So I'm hoping this is what it is.
I would go with the Biketronic load equalizer. I have the CD equalizer & it still has feedback when using the CB.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top