Road Glide banner

1 - 7 of 7 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
Thismorning i walked out and cranked my bike while standing beside it. I twisted the throttle and raced it upand let go. It didn,t spring back like itshould and the engine reved high. I twisted it back and it came down toidle. I shut offthe inition and did it again the throttletwisted back slowly. Didn't springback. It is a 13 RG ULTRA. Isit the throttle sensor.
 

·
Registered
Joined
·
85 Posts
Sounds like your throttle grip could possibly be getting stuck. I've had that issue, I just put some WD-40 and problem solved.
 

·
Registered
Joined
·
5,381 Posts
I had a little burr on my handlebars on my '11 causing it to stick. Pulled the grip, hit it with some fine sandpaper and problem solved. Another thing could be the grip is pushed in against the control housing causing a slight bind.
 

·
Registered
Joined
·
6,618 Posts
WD 40 isn't going to help. Did you do any work to the switch housing or throttle grips lately.
It sound like the throttle grip is in to tight on the TGS (Twist Grip Sensor) loosen the switch assembly a little and slide the throttle grip out about a 1/16 to a 1/8 of a inch then tighten everything down.
 

·
Administrator
Joined
·
12,480 Posts
I had a similar problem recently, it ended up being the intake gasket on the TB.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #7
I took the the brake and the twist grip off and checked the throttle position indicator for spring back return. There was no problem there. So I put it back together and it working just fine now. Thanks for the info brothers.
 
1 - 7 of 7 Posts
Top