Road Glide banner
  • Hey Everyone! Vote for the Site Favourite BOTM winner for the year of 2022 HERE!
1 - 7 of 7 Posts

· Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
Thismorning i walked out and cranked my bike while standing beside it. I twisted the throttle and raced it upand let go. It didn,t spring back like itshould and the engine reved high. I twisted it back and it came down toidle. I shut offthe inition and did it again the throttletwisted back slowly. Didn't springback. It is a 13 RG ULTRA. Isit the throttle sensor.
 

· Registered
Joined
·
6,648 Posts
I had a little burr on my handlebars on my '11 causing it to stick. Pulled the grip, hit it with some fine sandpaper and problem solved. Another thing could be the grip is pushed in against the control housing causing a slight bind.
 

· Registered
Joined
·
7,516 Posts
WD 40 isn't going to help. Did you do any work to the switch housing or throttle grips lately.
It sound like the throttle grip is in to tight on the TGS (Twist Grip Sensor) loosen the switch assembly a little and slide the throttle grip out about a 1/16 to a 1/8 of a inch then tighten everything down.
 

· Another ICON
Joined
·
13,701 Posts
I had a similar problem recently, it ended up being the intake gasket on the TB.
 

· Registered
Joined
·
66 Posts
Discussion Starter · #7 ·
I took the the brake and the twist grip off and checked the throttle position indicator for spring back return. There was no problem there. So I put it back together and it working just fine now. Thanks for the info brothers.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top