Road Glide banner

1 - 13 of 13 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I purchased the Sena wireless headset and had the WIM installed all my 2019 Road Glide Special. I’ve been to the dealer three different times trying to activate the Apple CarPlay with the wireless headset in use. The dealer can get it to work and the Apple CarPlay to operate correctly but it only last for 15 or 20 minutes. Once on the road the Apple CarPlay goes off and it is all just useless. All that money spent on the Apple CarPlay capabilities in conjunction with wireless headset have been so frustrating. Has anyone else had these kind of problems? Possible solutions?
 

·
Registered
Joined
·
240 Posts
I put the GTS and WHIM in my 2018 about a month ago (and bought the HD Sena 20s) and it has worked well on the few rides I’ve used it. I haven’t been out much because she’s been at the tuner and tore down for a few reasons.

If your dealer can’t get it right, maybe try another dealer. Make sure that the WHIM and Sena have the latest software updates.

Please keep us posted.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Thx for the ideas. Dealer did mention problems with iPhone 10xr. Phone and bike have latest updates. I’ll follow up with the WHIM being seated properly. Are the Sena 40’s any better? Is there a better manufacturer of wireless headsets? I wish I had ability to use the wired Harley headsets, at least from a communication stand point. I’m really disappointed in the WHIM and the Sena product
 

·
Registered
Joined
·
1,114 Posts

·
Registered
Joined
·
318 Posts
I purchased the Sena wireless headset and had the WIM installed all my 2019 Road Glide Special. I’ve been to the dealer three different times trying to activate the Apple CarPlay with the wireless headset in use. The dealer can get it to work and the Apple CarPlay to operate correctly but it only last for 15 or 20 minutes. Once on the road the Apple CarPlay goes off and it is all just useless. All that money spent on the Apple CarPlay capabilities in conjunction with wireless headset have been so frustrating. Has anyone else had these kind of problems? Possible solutions?
Are you using the H-D branded Sena headset or the Sena-branded?
 

·
Registered
Joined
·
1,114 Posts
Bottom line:

Loss of CarPlay functionality only come from one of two reasons.

1. Loss of communication between the BOOM GTS and iPhone via lightning/usb cable

2. Boom GTS no longer detects a connected MIC. Either 7 pin DIN or WHIM (WHIM is an interconnect between the BOOM and a Bluetooth headset, so there for is detected as a MIC). DIN and WHIM plug into the same harness.

IF YOU HAVE CarPlay activated via the WHIM box checked with no WHIM and you loss CarPlay functionality it is your USB/Lightning cable.
 

·
Registered
Joined
·
12 Posts
Thx for the ideas. Dealer did mention problems with iPhone 10xr. Phone and bike have latest updates. I’ll follow up with the WHIM being seated properly. Are the Sena 40’s any better? Is there a better manufacturer of wireless headsets? I wish I had ability to use the wired Harley headsets, at least from a communication stand point. I’m really disappointed in the WHIM and the Sena product
I have a 2019 RG CVO, Whim, Harley branded Sena 20s and Iphone 10 and it works flawlessly. I doubt it’s your phone.
 

·
Registered
Joined
·
43 Posts
I purchased the Sena wireless headset and had the WIM installed all my 2019 Road Glide Special. I’ve been to the dealer three different times trying to activate the Apple CarPlay with the wireless headset in use. The dealer can get it to work and the Apple CarPlay to operate correctly but it only last for 15 or 20 minutes. Once on the road the Apple CarPlay goes off and it is all just useless. All that money spent on the Apple CarPlay capabilities in conjunction with wireless headset have been so frustrating. Has anyone else had these kind of problems? Possible solutions?
I had the WHIM installed and bought a Sena 20s headset through the dealer. I could not get the headset to work with the Boom GTX. I don't have Apple Car Play though. Anyway, I had to go to the dealer on 3 different occasions to have them try and make it worked. That poor tech spent a total of about 18 on the phone with Milwaukee trying like hell to get it to work. They changed out the WHIM, tried other employee headsets, etc. Nothing. Finally they determined that my new Sena was bad and replaced it. I now have all the headset functions and it is really nice to have. All the labor and parts were run through warranty, so that was good. Good luck on yours,
 
1 - 13 of 13 Posts
Top