Road Glide banner

1 - 3 of 3 Posts

·
Registered
Joined
·
152 Posts
Discussion Starter #1
Hello all! New to the site and hopefully someone can help me out. I have a 2012 RGU with a little over 13K on it, just bought it last summer. I've noticed when the engine warms up I will hear a single metallic "ting" from inside the primary if I get on the throttle aggressively. It will do the same thing sitting in neutral or in gear riding down the road. Im thinking it may be the chain taping the inside of the case but not sure. If so could that be a tensioner issue possibly? Other than that it runs and rides great but that ting bothers me.

Thanks in advance!
 

·
Registered
Joined
·
8,832 Posts
Hello all! New to the site and hopefully someone can help me out. I have a 2012 RGU with a little over 13K on it, just bought it last summer. I've noticed when the engine warms up I will hear a single metallic "ting" from inside the primary if I get on the throttle aggressively. It will do the same thing sitting in neutral or in gear riding down the road. Im thinking it may be the chain taping the inside of the case but not sure. If so could that be a tensioner issue possibly? Other than that it runs and rides great but that ting bothers me.

Thanks in advance!
You really need to pull the outer cover and have a look and go from there. It could be a few things but probably is the compensator.
 

·
Registered
Joined
·
152 Posts
Discussion Starter #3
Thats what I was planing on doing to see if the chain has been hitting the cover. I don't think its the compensator because its just a single Ting with a good twist of the throttle. No problems at start up or when shutting off the bike, thats what makes me think it could be a tensioner.
 
1 - 3 of 3 Posts
Top