Road Glide banner

1 - 20 of 27 Posts

·
Registered
Joined
·
1,337 Posts
Discussion Starter #1
Went in for tires yesterday.... cam on right side axle twisted for the 2nd time chewing up the axle! Can't torque the axle down without the wheel kicking sideways.... ok... replace it under warranty.... sure.... NONE IN STOCK!!

SO... leaving on Friday morning for a 3 day ride, I decide to upgrade...

Zipper chromoly rear axle... $399... OUCH!

But she's not gonna move anymore...lol



Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
1,392 Posts
Nice, what's in going in?
 
  • Like
Reactions: Spazz

·
Registered
Joined
·
1,337 Posts
Discussion Starter #5
Glad to see you back on the forum Spazz.

Where have you been?

Swomack
Been super busy Swo....thanks.... I drop in and lurk when I can....

Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
6,527 Posts
Been super busy Swo....thanks.... I drop in and lurk when I can....

Sent from my SM-G955U using Tapatalk
That monster is looking better & better every time I see a picture.

How are you liking the windshield trim units?

Glad to see you back man.

Swomack
 

·
Registered
Joined
·
1,392 Posts
My 15 RGS... guess my 120 is too much for a stock axle...lol!


Sent from my SM-G955U using Tapatalk
Whoops, brain fart on my end.......somehow I was thinking it was something else. NICE piece, that ought to fix it .....or move it to the next weaker link, lol...
 
  • Like
Reactions: Little Wing

·
Registered
Joined
·
1,228 Posts
Went in for tires yesterday.... cam on right side axle twisted for the 2nd time chewing up the axle! Can't torque the axle down without the wheel kicking sideways.... ok... replace it under warranty.... sure.... NONE IN STOCK!!

SO... leaving on Friday morning for a 3 day ride, I decide to upgrade...

Zipper chromoly rear axle... $399... OUCH!

But she's not gonna move anymore...lol



Sent from my SM-G955U using Tapatalk
I would like to see some pictures after it is installed and let us know how well it works..


Mike
 

·
Registered
Joined
·
1,337 Posts
Discussion Starter #9
It's already installed... I'll take pics tonight when I get home and the test is a 1500 mile weekend starting tomorrow at 0530

Sent from my SM-G955U using Tapatalk
 
  • Like
Reactions: Brewiz

·
Registered
Joined
·
1,337 Posts
Discussion Starter #10
I would like to see some pictures after it is installed and let us know how well it works..


Mike
Well... had to go back and get a defective rear tire swapped.... PERFECT opportunity to get the Zipper axle pics...


Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
1,228 Posts
Thanks for the pics, can't wait to read the report on them. I may have to get these, can't get my bike to track straight to save my life, this may be the fix...
 

·
Registered
Joined
·
1,337 Posts
Discussion Starter #12
Thanks for the pics, can't wait to read the report on them. I may have to get these, can't get my bike to track straight to save my life, this may be the fix...
I'll check everything out when I get back and report findings(if any)

Sent from my SM-G955U using Tapatalk
 
  • Like
Reactions: Brewiz

·
Registered
Joined
·
1,337 Posts
Discussion Starter #13
That monster is looking better & better every time I see a picture.

How are you liking the windshield trim units?

Glad to see you back man.

Swomack
Windshield trim lights by CD are awesome! Lots of complements and people actually say they are pretty same bright from a rear view mirror perspective

Sent from my SM-G955U using Tapatalk
 
  • Like
Reactions: Brewiz

·
Registered
Joined
·
7,569 Posts
Spazz, thanks for posting Bro!
I ordered the Zipper's Axle & Adjuster Kit on the 19th and just waiting for the Big Brown truck to deliver it.
I'm hoping they work as advertised as I do believe the MOCO made a big mistake with those damn rear axle adjusters.
Mike U.
 

·
Registered
Joined
·
1,337 Posts
Discussion Starter #17
Bike is looking good brother....what was up with the tire ??? Enjoy your ride and be safe .....


Sent from my iPad using Tapatalk
Thanks Brother...

Over 85mph... I had a slow 'WEAVE'... New rear tire fixed it

Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
1,337 Posts
Discussion Starter #18
UPDATE:

So... my trip didn't go as planned, bit I can report.... lemme explain in short.

I was headed to Mesquite, NV for an event... 525 miles one way.

Left at 0530 Friday and around 3pm... 420 miles out.. my phone rings.

Wife in ambulance being rushed to ER... SHIT!

2 of my Brothers went on... another Brother road back to Reno with me... 845 miles total and got home at 1230 am... long day

Wife is now home after 2 days in ICU and 1 in normal room... all good

Now for the report..lol!!

Belt tension was EXACTLY the same as before I left.... there is NO WAY this axle can move on it's own. Adjusters are locked down with a nylok nut.. so that would be the only thing I might change every 2 or 3 tire s just be be safe.

It's not cheap... bit it works


Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
7,569 Posts
Hey Spazz, sorry to hear about the Mrs. I hope she is doing well.
Thanks for posting about the way the new axle is working.
I'm still waiting on mine to arrive.
UPS lost it and told me it would be 8 work days bedore they have an answer.
What a croc. Lost is lost as far as I'm concerned.
Mike U.
 

·
Registered
Joined
·
612 Posts
Hey spazz sorry to hear, and hope she is doing better. I know exactly how it goes to get somewhere and turn around as I been in the same spot more than once.

Glad to hear the axle is performing flawlessly..


Sent from my iPad using Tapatalk
 
1 - 20 of 27 Posts
Top