Road Glide banner

1 - 8 of 8 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
got a 2015 RGS around 25000 mls on it and just had a stage 3 kit put on it.. Put around 300 miles on it so far in the break in and keep hearing tapping sounds from the engine. Is this normal while I break it in or should I let the dealer know about it before it gets worse or I do damage to the motor.. hear it in all RPM ranges,, worried.
 

·
Registered
Joined
·
59 Posts
got a 2015 RGS around 25000 mls on it and just had a stage 3 kit put on it.. Put around 300 miles on it so far in the break in and keep hearing tapping sounds from the engine. Is this normal while I break it in or should I let the dealer know about it before it gets worse or I do damage to the motor.. hear it in all RPM ranges,, worried.
Take it back under dealer warranty my 2010 same thing
bent pushrod no charge no issues in 12000 miles since wait oil pan gasket replaced this winter drop off helped offset winter storage cost
 

·
Registered
Joined
·
654 Posts
I would have it checked to be on the safe side. I know that the higher lift cam of the stage 3 kit will cause a little more valve train noise than you had previously. Did you have a high flow air cleaner installed at the same time? You will get hear some noise from the throttlebody now that it's more open than it was.
 

·
Registered
Joined
·
1,336 Posts
keep an ear on it. if it goes away after warmed up it's prolly just a pushrod adjustment.
if it were my bike that just had the work done i'd take it back and have them check it.
 
1 - 8 of 8 Posts
Top