Road Glide banner

1 - 11 of 11 Posts

·
Registered
Joined
·
299 Posts
Discussion Starter #1
I have a 2012 RG Custom. I was told that once the bike is running and when you hit the start button again nothing will happen. Is this true? When I hit mine again it tries to engage the starter.

The reason I am asking is my Indy installed new bars and I have been having some button issues. I went on a 1800 mile trip and had to see a stealer to inspect my starter issues and they told me that my model year should not be able to restart.

Thanks for any input
 

·
Registered
Joined
·
7,556 Posts
Mason, I have a 2012 also and if I hit the start button while it's running it tries to engage the starter also.
I thought that was normal as it also did it on prior bikes that I had.
Mike U.
 

·
Registered
Joined
·
8,826 Posts
Hitting the start button when the engine is already running is like hitting the brakes while your rolling on the throttle. :grin:
 

·
Registered
Joined
·
4,175 Posts
Hitting the start button when the engine is already running is like hitting the brakes while your rolling on the throttle. :grin:
As odd as that seems, my friend, might keep your
six outta a ditch, now where fores that button amateurs
should leave the "little man in the boat" alone.
 

·
Registered
Joined
·
8,826 Posts
As odd as that seems, my friend, might keep your
six outta a ditch, now where fores that button amateurs
should leave the "little man in the boat" alone.
Or put your six in the patch.
 

·
Registered
Joined
·
299 Posts
Discussion Starter #11
The reason why I asked this question is the the 2014 and newer models do not engage while running ( they have new switches on them that are different from earlier models).

I am having starter issues and I never hit the start button after I have mine running, but it turns out I have a faulty switch and it has been replaced.

I was making sure my bike was not the only one that does that. I am checking to see if the mechanic was not talking out of his butt.
 
1 - 11 of 11 Posts
Top