Road Glide banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
On my '02 RG the starter makes an awful gnashing, grinding sound. The solenoid doesn't seem to stay engaged when starting it. It will turn it over then quit then turn it over again if I hold the start button. This just started a few months after replacing the starter and solenoid with a stronger than stock one. Anyone out there have similar problems? Thanks GEZR.
 

·
Registered
Joined
·
823 Posts
My guess: 31516-94A - Starter Clutch Assembly.
 
  • Like
Reactions: RGKen

·
Registered
Joined
·
7,299 Posts
check the battery too
 

·
Registered
Joined
·
6,650 Posts
It just may be the compensator sprocket in the primary.
 

·
Registered
Joined
·
989 Posts
My guess is the battery or the starter clutch. Had 2 of em go out on my 02. One of em took out teeth on the ring gear.

Lil Chief
 

·
Registered
Joined
·
6,650 Posts
Well we are all guessing but being the bike is a 02 it just may be possible that the compensator is going bad. Not saying that there isn't other issues that can cause the problem but it still wouldn't hurt to check the comp. Also when you have the primary cover off you can check everything inside the primary. Hell it could just be a worn out primary chain tensioner and the primary chain may be binding up.
 

·
Registered
Joined
·
4,198 Posts
okif we're going shotgun this,
Dose it do it starting in neutral?
How many miles on the switch house contacts???
Have you had to take a hammer to it yet?
 
1 - 8 of 8 Posts
Top