Road Glide banner

1 - 9 of 9 Posts

·
Registered
Joined
·
410 Posts
Discussion Starter #1
Any suggestions on what could be wrong, I have pulled fairing and checked all seems good, it just goes blank and just started about a week ago. Radio still plays just the screen is blank.
 

·
Life Member
Joined
·
5,434 Posts
Mine did it this afternoon following a hardy washing at the local coin op car wash. Let her dry for awhile and all is good again. Good thing I use my Iphone and Pandora for my music listening pleasure.
 

·
Registered
Joined
·
1,521 Posts
Mine used to do it. I would tap the display with my fingertips and it would come back on. If you are still in warranty, I would see the dealer. Out of warranty? Contact Iron Cross Audio. I think the fix is about $250 and they'll go through the radio and update with any new patches. They did mine and all is well thus far. Good luck
 

·
Registered
Joined
·
7,236 Posts
Yup mine does it too. Radio still plays but no screen from time to time. Right now though i dont see it as an issue cuz when it does finally take shitter im gonna go aftermarket like a good majority of our RG members seem to do.
 

·
Registered
Joined
·
875 Posts
Happened to my 06, 3 times. Pretty common on the HK head units.
Should be replaced under warranty.
MOCO\HK uses refurbed units for warranty, at least that was my experience. Had mine replaced for intermittent screen blanking a few months ago. After getting the refurbed unit I replaced with a Sony HU. HK's in a box on the shelf. My opinion is the HK is an inferior HU, but it does have the HD logo :D Maybe thats why they cost so much.
 

·
Registered
Joined
·
410 Posts
Discussion Starter #9
Now my faceplate won't light up at night, have an apt for Sat morning. Still under warranty, but will replace with aftermarket once my warranty is up in Apr 14
 
1 - 9 of 9 Posts
Top