Road Glide banner
1 - 3 of 3 Posts

·
Registered
Joined
·
985 Posts
Discussion Starter · #1 ·
Seems like my right thumb control is sticking but it's not. Won't stay on a station or a song on ipod or usb thumb drive. I called the company i got the deck from and they told me to reset the module that runs the thumb controls and i did. Works fine for 3-4 hours then started doing the same crap. Its a Kenwood marine deck. I'm thinking its the deck or could it be the module. I'm frustrated and tired a taking off my fairing :-(


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
1,431 Posts
Sounds to me like it might be the module,since resetting it fixes the problem temporarily.Perhaps the module is overheating or has a faulty processor,or perhaps is corrupting it's software.if it was the deck,it would keep doing it no matter what happened with the module.

Can you disconnect the module from the head unit and check it without the hand controls or module connected? that should narrow it down.

BTW,were you at the Beartooth rally last weekend?
 

·
Registered
Joined
·
985 Posts
Discussion Starter · #3 ·
Yea i Was at the Beartooth rally. Wasn't near as good as last year. I'm thinking cause a lot a people are saving $ for Sturgis next week. I should a done same thing cause i had to get a back tire in Red Lodge and it cost me $430 installed :-(.
Thanks for the input on the module. I didn't think about it as you said it. Resetting it did fix it for a while. Then it messed up again. Thank you


Sent from Motorcycle.com Free App
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top