Road Glide banner

1 - 6 of 6 Posts

·
Registered
Joined
·
334 Posts
Discussion Starter #1
I am doing a stereo install since i was planning on disconecting the battery i pulled the ecm fuse per the T-Max instruction sticker... my issue is that my seat rubbed off the other part of the instruction.... I can see something about re installing the fuse, then 20 seconds....

If you have the t-max sticker available could you please relay to me the reinstall options?
 

·
Registered
Joined
·
6,539 Posts
Anytime you disconnect the power on the bike by disconnecting the battery or pulling the main fuse you need to reset the T-max module. To reset the you need to reconnect the power then make sure the on/off switch on the handlebar is in the ON position then turn the ignition ON for 20 seconds making sure you do not move the throttle, then turn the ignition OFF and wait for 20 seconds then you can turn the ignition ON and start the bike.
 

·
Registered
Joined
·
84 Posts
T-max

You need to do the 20 seconds on 20 seconds off three times before starting.
On you third 20 seconds on turn the bike off before trying to start.
 

·
Registered
Joined
·
6,539 Posts
You need to do the 20 seconds on 20 seconds off three times before starting.
On you third 20 seconds on turn the bike off before trying to start.
No need to do this 3 times.

Initialization Procedure;
When 12V power is interrupted you need to;
Turn ignition switch ON and handlebar switch to RUN for 20 seconds uninterrupted.
Then cycle the ignition switch OFF and ON, then start the engine.
Let the engine idle on its own for 15 seconds.
Cycle the ignition OFF and restart the motorcycle; normal idle speed should be attained depending on engine temp.

This is according to the T-Max instruction manual.
 
1 - 6 of 6 Posts
Top