Road Glide banner

1 - 12 of 12 Posts

·
Registered
Joined
·
891 Posts
Discussion Starter #1
The rear latch on my Tour Pak no longer "locks" into place. It has so much free movement that it doesn't engage the catch on the lid. It looks likes its closed but you can see a gap between the 2 parts. Anyone else have this issue and if so, what did you do to fix it. Otherwise, any suggestions (other than sell the bike) would be appreciated.
 

·
Registered
Joined
·
6,537 Posts
I put the HD premium tour pak latches on my tour pak and they been real dependable. Try replacing the stock latches with the premium latches.
 

·
Registered
Joined
·
693 Posts
The rear latch on my Tour Pak no longer "locks" into place. It has so much free movement that it doesn't engage the catch on the lid. It looks likes its closed but you can see a gap between the 2 parts. Anyone else have this issue and if so, what did you do to fix it. Otherwise, any suggestions (other than sell the bike) would be appreciated.
as stated above the premium latches are much better, also replace the hinges with the premium ones, my oem hinges had too much slack in them and you had to wiggle the top to get it to sit right and let the latches catch correctly. i was doing away with the chrome and going black and went with the premium latches and hinges and it makes a big differance, i don't know why the moco puts the cheap stuff on a $30,000 bike (yes i do) just so they can up grade us to the proper epuipment. there is a lot of small stuff on these bikes that the aftermarket is yrs ahead in quality and performance.
 

·
Registered
Joined
·
8,242 Posts
I hadn't used the premium latches but replaced with the same. They're only about $15 bucks and easy to replace if I remember right.
 

·
Registered
Joined
·
1,568 Posts
Mine wasn't too loose but rattled. I got some adhesive backed seal from lowe's & put a small piece on the top latch surface. Snug & no more rattle.

Hope you're doing good.
 

·
Registered
Joined
·
1,926 Posts
The rear latch on my Tour Pak no longer "locks" into place. It has so much free movement that it doesn't engage the catch on the lid. It looks likes its closed but you can see a gap between the 2 parts. Anyone else have this issue and if so, what did you do to fix it. Otherwise, any suggestions (other than sell the bike) would be appreciated.
I’ll do a search this weekend for my chrome latches that I replaced with black. If I can find them I’ll send them to you. No promises though. I may have thrown them out.
 
1 - 12 of 12 Posts
Top